Please help me fix my videos

Seems to be caused by the combination of Samsung and twonky (worked okay before Samsung upgrade, still works okay with Plex).

So for the future, maybe ask Samsung why their video encoding no longer works with a very widely-used media server.

Its possible the android update used a slightly different encoding codec for video causing Twonky to miscategorize it as audio rather than video. Or its possible it is adding some metadata to the video file that Twonky is misreading.

One suggestion that has worked for some when the video is not categorized properly is to access the Twonky Administration > Advanced page (http://mycloud:9000) select Clear Cache, then select Rescan Content Folders. It may take Twonky a while to rescan and rebuild the media database.

I’ve tried rebuilding/rescanning the library many times, with no luck. I tried a wd cloud reset, with no luck.

The Twonky Administration page is different than the My Cloud Dashboard > Settings > Media page. If you haven’t tried the Twonky Administration > Advanced page (http://mycloud:9000), it couldn’t hurt to go to that page, select Clear Cache, the select Rescan Content Folders page. It also might be a good test to select the Reset to Default button on that page too.

i found that renaming .mp4 to .mkv then doing a rebuild has sort of fixed it (file previews and playback), The only file that dont workat those captured at 60fps. So while it isnt a complete fix, it will have to do until WD fix this! I cant see how it is a Samsung issue seeing as other DNLA servers I have tried on my PC all correctly show the mp4s as video files

You will be waiting a long time, then. WD’s attitude towards Twonky is that it is a third-party piece of software (it’s not written by WD, but bought in from PacketVideo, or whoever owns it now…), and even though it comes bundled as an advertised feature of the MyCloud product, they essentially refuse to support it in any meaningful way.

MP4 and MKV are entirely different, incompatible container formats; if you are renaming an MP4 file to MKV, you are doing it inappropriately. It you want to rename an MP4 video to an extension the may identify it as video, then the usual extension is M4V, although that isn’t an official extension of the MPEG4 standard.

if i rename the files as m4v they still shows as audio, if i rename them as mkv they show as video and play on both the TV and chromecast so i don’t have any better option than to do it inappropriately

I don’t care what you call your files; if it makes them work, then call them what you like.

The point I was trying to make is that, if changing the extension so that they are identified as Matroska container format files, rather than MPEG4 container files, makes them be recognised correctly, and play correctly, then maybe they really are Matroska container format files, and your Samsung has mis-labelled them as MPEG4 container files…

1 Like

That is a little strange though-- MKV is… very different… from naked MP4.

It is interesting to me that Twonky knows what mkv is though. Most such things treat MKV as a red-headed stepchild, despite it being the better format for ripped dvds, due to the seamless support for soft subtitles, and multiple audio streams.

Makes me want to examine that sample file more closely…

Does anyone fond a solution to this weird Samsung/Twonky related problem? I also have some files recorder by S6 phone which are categorized as audio, but only those which were made before 2017 year. Is there a way to update Twonky on 64K firmware?

Best regards
Andrew

I still just rename the .mp4 files that don’t show as video to .mkv it is the quickest and easiest fix without the devs sorting the bug.

Yesterday evening I found another solution, I installed miniDLNA and I think I will stay with it.

Best regards
Andrew

How do you install that on a my cloud device?

Never mind it doesn’t even have a web interface so for me renaming an extension is far easier

I installed it with a script from this topic:

On a web page it shows how many files (audio, video, music) is in a database and content scanning status - when it is scanning then there is info about it.

MiniDLNA should also be able to show the subtitles but I didn’t test it yet - on twonky it was impossible.

Best regards
Andrew

SRT subtitle files will play using Twonky Media Server provided one downloads the SRT file to the same directory as the video file, and names the SRT file exactly the same as the video file.

Hi there,

Sorry to jump on this thread but I am going out of my mind trying to sort a similar problem. I am in the process of converting my dvd collection to my WD My cloud drive and keep getting this same issue with some,or all of my videos being labelled as music files after they have been transferred. I have been using WinX to rip my dvds,and have been doing them in mp4 format (which I am guessing may be part of the problem) but when I copy them onto the drive,some or all of them appear as music files.I can play/watch them as videos on my tv,through the music folder,and if I log into the dashboard,and rescan the drive,they all turn into videos again. But I am getting a little fed up with having to do this each day after I have finished ripping.

Anyone else had/figured out a fix for this? I could change the file format of the rest of my dvds when ripping,but I’m not sure my ocd could cope with not having all the same file type.

Won’t speak for others but in my case when the My Cloud Twonky media server misclassifies video files as audio files it is often because of the encoding codec used when encoding MP4 files. Using programs like Handbrake or XMediaRecode I no longer have problems with video being misclassified as audio.

Check the encoder settings used by WinX, experiment with different settings.

Thanks for your reply,

What is confusing me,is that if it’s something to do with the encoding,then why if I repopulate the file list does the drive then classify them correctly as video files? I don’t know if there is an answer to this,just have to ask as it is a little frustrating.

Love the WD drive and the app,but this is the one mild annoyance I have at the moment.

Could be the version of Twonky used on the My Cloud is having trouble properly reading media files due to the encoding codec used. The version of Twonky used on the My Cloud is old and was “beta” at the time WD included it into the My Cloud firmware. As a troubleshooting step remove any metadata using a metadata editor like MediaMonkey or Mp3Tag. It is possible Twonky is reading the file metadata and misclassifying the media.