Please help - MBWE II appears dead

Hello, folks. I’m hoping someone can help me. My WD My Book World Edition II (white lights) kept disconnecting from the network, so I tried to follow some instructions online to make it re-index its files. Before I could even complete that, however, it kept disconnecting – and now the network doesn’t see it at all. 

The white light still is lit. And yesterday, when I restarted it after having it off, it whirred like crazy for hours, so something’s working – but now it’s silent, and the network still doesn’t see it. 

I tried pulling the drives and putting them into a drive reader, but my Windows 8 computer doesn’t recognize them. I tried opening them in a Linux window, but it doesn’t seem to see them. So I put them back in the MBWE and ran an ethernet cable straight to my laptop, but it still doesn’t see it. 

Disclaimer: I’m pretty comfy with Windows (and was able to do the above stuff), but I honestly have no idea if I did it right. I don’t even know how to search for a new drive in Linux. Can someone please help me walk through whatever steps I should do (even BASIC steps!) to: a) restart my MBWE, b) make my drives visible via my drive reader, or c) recover my data?  

RAID array. All our family photos, music, etc. on there (I thought the mirrored setup made that a safe backup!). Any help would be appreciated!!


Hi, have you tried using another Ethernet cable. You can also try pressing the reset button on the back of the my book for 4 seconds.