Please help a complete technophobe get started

Hi, I am very new to this and a real technophobe so please bear with me. About 2-3 years ago I bought a WD My Passport Ultra external hard drive. I initially tried to install it on my home PC(Windows 10) but failed and gave up. I am now trying again. There are no instructions with it. Obviously it is plugged into my PC and the light is on. I can see that there is WD Backup, WD Security and WD drive utilities on my desktop. I have registered the product. I still don’t think my PC recognises the device. When I check my devices it does not show up. So I am thinking I obviously need to download something. I always thought Windows 10 would automatically find a device. What do I need to do to get this working. I have so many files I need to save. I would be so grateful of any help in words I can understand. TIA.

Hi,
When you say the install failed, what do you mean? There is no install needed, you just plug it in.
It’s odd that the drive didn’t appear when first connected to your pc.
Go here and get the instruction manual:
http://products.wdc.com/library/?id=1574&type=25&cn=4779-706009&lang=en
See page 7 how to install WD Discovery.
You shouldn’t have to install WD Discovery to have your drive appear, but it’s worth a try. If you still can’t get it to appear, I’d call WD customer service for help. I’ve used them. They are very good.
The drive does have a 3-year warranty, but you may be out of warranty.
I have two external WD drives for backup, and they work well with the WD software.
Good luck.

One other thing…if you have another external USB drive, or even a USB flash drive, plug it into the USB port to see if the port is working. Or, plug the WD drive into another port. It could be that the USB port you are using is not working.
Finally, go here:
https://support-en.wd.com/app/answers/detail/a_id/12455
and click on the upper left link, DAS. There are some other tips there.
Again, good luck.

Hello BruceK,

Thank you for taking the time to respond. I did not realise that I do not need to download anything.
When I go onto my PC and look for devices it says: attach a supported WD Drive.
When I try to move files (Send to) there is no option to send to an external hard drive.
Looking through and playing around and trying to do a WD Backup it says No writable partition found.
I tried looking at page 7 and to follow those instructions and download but it then says the item is already on my PC.
I have tried moving the USB to different ports and it does not work in any of them. However other devices work using those ports.
I will read through some of the other stuff you have told me and contact the WD support,.

Thanks again. I really appreciate your help.

OK. I see. Sounds like that since you are getting, “attach a supported WD Drive”, you have one of the WD utilities, like Discovery, already installed and you launched it. But, since when you try to send (or copy) a file from your pc, and there is no external drive that shows up, AND since moving to different USB ports makes no difference, your best bet is to call WD. I have other ideas, but they could probably get you up and running, or discover that the drive is bad, faster than doing this over the forum.
WD utilities could diagnose our drive, but only if your pc can ‘see’ it.