Please fix the iPlayer abrupt ending issue once and for all!

Ever since the iPlayer service was added to the Live SMP it has had a fault where EACH and EVERY programme ends abruptly with a few minutes remaining.

Imagine you’ve spent an hour, or longer, watching something and just as it’s getting towards the end and climax the screen turns black and you’re back in the menu.

This happens to every programme and has been reported countless times yet despite numerous new firmware releases this still hasn’t been fixed.

Forgive me for saying this but I’m sure if this issue affected every Hulu Plus show (being American) the issue would have been sorted immediately but as this issue only affects those of us in little old UK no-one seems bothered about fixing it. Care to prove me wrong and fix the problem so we can actually use the SMP for one of the reasons we all purchased it?

28th October Update 

Thanks for the continued replies to the thread. It’s encouraging, if also disappointing in one way, to see so many people unhappy with this issue speaking out vocally.

It’s my firm belief that if this issue affected a major US networks “repeat service” then WD would act immediately but because this only affects little old UK, a smaller percentage of their customer base, then they couldn’t care less.

It’s also my strong belief that the only way to resolve this is to hit WD where it hurts. I.E. Make a noise and complain directly to them. If necessary request a refund on the grounds that the device is not fit for purpose. After all they promote and market the device as iPlayer compatible when in reality it’s not.

I’ll be contacting a few UK bodies tomorrow, the ASA being merely one of them, to see what they have to say about a company advertising and selling a product which doesn’t do what it says on the tin. 

Maybe then WD will sit up and take notice. 

Some may think those of us in this thread are making an issue out of nothing and should shut up and go away but if you’ve purchased a product, based on the fact you’re told it fulfils a requirement you’re after, namely iPlayer, and that it fails to deliver then we should have our concerns respected and acted upon. 

I strongly encourage anyone who’s purchased this device with iPlayer as their main purchasing factor to complain to WD and complain strongly. They may in turn blame the BBC/iPlayer but it works perfectly well on numerous other devices.

3rd November Update


Since my last posts on this issue, and the small misunderstanding, I’ve received a couple of emails from WD support.

I won’t post a direct quote as it’s no doubt again the rules but suffice to say they’ve now identified the cause of the issue and they are working on a solution.

Although we’ve put up with the issue for a long time it’s encouraging that they’re now actively working on a fix.


1 Like

I’ll second this … but frankly the chances that anything will be done are almost zero.  

I raised this with the BBC - they claim there isn’t a problem (and claim they tested it on their equipment - so they evidently have their own wonder firmware or device!!!).   I’ve submitted numerous complaints - same old stock answer that there isn’t a problem.

The last notice on this as a WD bug has been under 'investigating ’ by WD for weeks.

I switched to Roku because of this issue - but then they released a disastrous firmware update (since withdrawn) which made iPlayer unusable.  Their ‘engineers’ seem as smart as the Beeb’s and WD’s - still no fix.

These STBs are getting to be a joke and a consumer rip-off - they are really only interested in getting another ‘money-grabbing’ box into your home.  

Sadly it seems you’re right and WD couldn’t care less. At least that’s the general feeling that comes across.

Maybe I’ll submit an RMA request and see if they take the issue seriously then. I doubt it however.

To misquote the SEX PISTOLS …

They’re so vacant … and they don’t care

Personally, I consider this an absolute disgrace and the fact that iPlayer is crippled should be printed on the box and in all their advertising material.   

They count on the fact that users just give up in frustration.

I for one will never buy another WD device.

I’ll continue banging on about it and make sure I refer to it in any other posts I make on other media forums.

castalla wrote:



I’ll continue banging on about it and make sure I refer to it in any other posts I make on other media forums.



Yes, we’ve noticed.

Steve W

For what its worth, Iplayer works fine on both my WD Boxes - nothing cut short, plays til the end.

Really? I find that hard to believe. 

You’ll have to forgive my scepticism as even WD accept the fault occurs and every Live owners I’ve ever spoken to personally also has the same issue. 

I’m complaining because I paid good money for this device - it is currently not fit for purpose.

Well, that’s one user and the BBC claiming there’s no problem vs. many others who report the fault (and no-one knows how many others out there just accept the defect and don’t complain).

I have read some reports which claim the cut-off only happens on short programmes - I’ve tried many different ones, and they all cut off.

There was a recent firmware problem with the Roku iPlayer - seems that Roku at least are doing something about it and are testing an update to fix the problem.  

I find it also unacceptable that WD seem incapable of giving users some feedback on this problem. 

“Really? I find that hard to believe”

Then believe, i watched the olympics opening ceremony to the end, several tv programmes to the end in the last few days alone - works fine for me.

If that’s the case, then please give the specific programmes, so others can test them.

Which firmware are you using?

Latest firmware D/loaded 1.10.13

Olympic opening ceremony (without commentary if you can still view it)

The Dark  - Natures Night

Cant remember the other one, but both played til the end here, UK

I haven’t updated the firmware …

Can anyone else with the latest test out these programmes?

I’m running 1.10.13 (not that it matters as this issue has occured in various firmware revisions)

Testing “The Dark…Natures Nightight World” it says it’s exactly 59.00 minutes long but it ends abruptly at 58.41 and goes back to the iPlayer menu. Either I’m unlucky or the other posted didn’t test it properly. This is one of the better results as at least it cuts out during the end credits. 

If you try “Engineering Giants” (three programmes) which I’ve watched this week all will end before the end.

The same can be said for “Olympics Most Amazing Moments” which counts down from number 50 to 26 (and 25 to number 1) Both episodes cut out at the climax of each episode.

In fact I challenge anyone to find a programme on iPlayer that doesn’t end abruptly. 

(Edit - I also watched all three episodes of series 2 of “Worlds most dangerours roads”. All ended before the end)

As an afterthought I’ll update this thread as and when I watch something on iPlayer stating the length of programme and the point at which it end abruptly. 

I just checked with Th Dark - bombs out during the credits.

In fact there’s no need to watch a programme painfully through to get the cut-off - just fast forward to a point about 2 mins. from the end watch as the stream ends abruptly - EACH and EVERY time.

I also tried the Olympic opening ceremony this morning and that too ends with about 30 seconds remaining so that’s both programmes  barnaclebill said played back which don’t. 

Don’t forget that the BBC also claim there is no problem either!

Maybe there are some tweaked devices out there somewhere???!!!

i dont think theres any tweak i i think there just not very observent. btw a guy on another forum said the beeb told him that if it runs short to check the following program it could be attached to the beginning lol :confused: also i believe the tivo media player uses the same api as wd uses and that also runs short on programmes…

Its nothing to do with it being attached to the next program. It always stops approx 2 minutes short of the time displayed and on other versions of iPlayer (PS3) it works perfectly. I have found that if I go manually to a point 2 minutes before the end I can sometimes get most of the ending. I agree that this a most annoying bug because on a lot of occasions the most important things happen in the last couple of minutes.

Here’s what the BBC suggest (seriously):

"We are aware that some users are experiencing problems with programmes being cut short, or with a programme not being available in full.

If this is the case, you may wish to check if the missing programme content is available to view at the beginning of the following programme broadcast on that network."

If anyone here wants to pester the BBC about this, try here: