PLC-Link not working


I have 4 livewire units installed on the same powerline. Three of them are working fine and has PLC-Link working, but on one unit PLC-Link is not showing. I reset all 4 units and restarted them 3 worked fine but this particular unit did not. Also tried syncing them manually.

In livewire utility I can see 3 units but this one is not showing. I connected to this unit and tried adding other units manually but that also did not work and gave message “unable to set NMK of remote device”.

Can anyone help with this? Thanks for your time.

In the Livewire utility, the unit plugged in to your router will be displayed in the upper box and the other units on the network will show in the bottom box.  In your case, only 3 devices should be showing in the bottom box.

When you say the PLC-link is not showing what do you mean?  The PLC-Link light is not lit up on the device?  Or, it’s not showing in the Livewire Utility?  Is it possilbe the device is working despite the indication?  Can you try to move data between your remote device to verify?

Does the 4th unit (the one that currently does not work) work correctly if plugged into the same outlet as one of the devices that DOES work?

If so, then it’s possible the power circuit isn’t clean enough for the Livewire to work.

In livewire utility, I see only 2 units at the bottom and 1 unit on the top. So, this unit does not show up in the bottom. Also, if I connect to this unit with Livewire, it does not show ANY unit at the bottom.

I’ve put all 4 units in the same room and on the same powerline. When I switch on all the units, the PLC-Link light goes away for a couple of seconds and comes back on 3 units (so they are connected), but on this unit, the PLC-Link light goes away for good.

I tried syncing them by pushing the sync button on all units, but that also does not help for this unit.

Hope this clarifies the situation.

Thanks for your time.

Must be a dead box.