Playback stutters on MKV videos


#1

I’m getting really bad stuttering and sync/no audio playback on the WD TV Live when streaming MKV files (both 720p and 1080p) from network shares. Usually at a fast motion scene the playback will begin to stutter then picture will accelerate somewhat and there’ll be no audio for a while and then eventually it’ll sync up again and play smoothly (until the next fast motion scene).

How do I get the WD TV Live to playback MKV smoothly?

P.S. - I’m using a 300 Mbps wireless-N USB adapter on a 300 Mbps wireless-N network and I’m connecting to the TV via HDMI.


#2

It’s probably that the bitrate of those scenes is too high for the network or server to handle.   You could try re-encoding them to lower the bitrate.


#3

I don’t think its that. My other media players/streamers don’t have a problem playing these MKV files, I even played them simultaneously on different players and got no hiccups at all. Only the WD TV Live has these problems :frowning:


#4

No, Tony’s right.  The Live definitely has issues with high bitrates over wireless – try wired and if it works that way you know what the problem is.


#5

I’m giving up. I’m having way too many issues getting this thing to work. I’ll just build a mini-itx HTPC machine :confused:

Thanks everyone for help


#6

Hi, first post (yey!) I’m having spot on the same problem, but it’s not a network thing as it won’t play when connected to an external HD either.

I got my live a few days ago and so far none of my .MKVs are playing games. They’ll be fine for a few minutes then the audio will switch off and the video playback will go to 1.5x or so. The only way I’ve found to sort it is by rewinding for a couple of seconds then playing again. This works fine for a few more minutes until it all starts again!

I’ve tried remuxing it with mkvmerge - all that did was kill the sound, and I’m going to try reducing the bitrate with handbrake overnight, though I’m not too confident that will do anything as the 'rate isn’t that high to begin with.

Any thoughts??

Details of one of the files are here:

General
Complete name                    : D:\Episodes etc\HD Films\Avatar 2009 1080p BluRay X264-AMIABLE\avatar.2009.1080p.bluray.x264.mkv
Format                           : Matroska
File size                        : 10.9 GiB
Duration                         : 2h 41mn
Overall bit rate                 : 9 674 Kbps
Writing application              : x264.exe
Writing library                  : mkv2rls v1.2 (date: 2010 febr 17)

Video
ID                               : 1
Format                           : AVC
Format/Info                      : Advanced Video Codec
Format profile                   : High@L4.1
Format settings, CABAC           : Yes
Format settings, ReFrames        : 4 frames
Muxing mode                      : Container profile=Unknown@4.1
Codec ID                         : V_MPEG4/ISO/AVC
Duration                         : 2h 41mn
Bit rate                         : 8 171 Kbps
Width                            : 1 920 pixels
Height                           : 1 080 pixels
Display aspect ratio             : 16:9
Frame rate                       : 23.976 fps
Color space                      : YUV
Chroma subsampling               : 4:2:0
Bit depth                        : 8 bits
Scan type                        : Progressive
Bits/(Pixel*Frame)               : 0.164
Stream size                      : 9.00 GiB (82%)
Writing library                  : x264 core 93 r1542 5b86182
Encoding settings                : cabac=1 / ref=4 / deblock=1:0:0 / analyse=0x3:0x133 / me=umh / subme=7 / psy=1 / psy_rd=1.00:0.00 / mixed_ref=1 / me_range=16 / chroma_me=1 / trellis=1 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=-2 / threads=12 / sliced_threads=0 / nr=0 / decimate=0 / interlaced=0 / constrained_intra=0 / bframes=3 / b_pyramid=2 / b_adapt=1 / b_bias=0 / direct=3 / wpredb=1 / wpredp=2 / keyint=240 / keyint_min=24 / scenecut=40 / intra_refresh=0 / rc_lookahead=30 / rc=2pass / mbtree=1 / bitrate=8171 / ratetol=1.0 / qcomp=0.60 / qpmin=10 / qpmax=51 / qpstep=4 / cplxblur=20.0 / qblur=0.5 / ip_ratio=1.40 / aq=1:1.00

Audio
ID                               : 2
Format                           : DTS
Format/Info                      : Digital Theater Systems
Codec ID                         : A_DTS
Duration                         : 2h 41mn
Bit rate mode                    : Constant
Bit rate                         : 1 510 Kbps
Channel(s)                       : 6 channels
Channel positions                : Front: L C R, Side: L R, LFE
Sampling rate                    : 48.0 KHz
Bit depth                        : 24 bits
Stream size                      : 1.71 GiB (16%)
Title                            : English DTS 1509kbps
Language                         : English

Text #1
ID                               : 3
Format                           : UTF-8
Codec ID                         : S_TEXT/UTF8
Codec ID/Info                    : UTF-8 Plain Text
Title                            : English
Language                         : English

Text #2
ID                               : 4
Format                           : UTF-8
Codec ID                         : S_TEXT/UTF8
Codec ID/Info                    : UTF-8 Plain Text
Title                            : English
Language                         : English

Thanks!


#7

Welcome aboard!  

You’re right.   That bit rate shouldn’t be a problem.  Your Avatar rip is about 2/3 the size of mine, and mine is fine.

Are you using Wireless?  What are you using to serve the video?  Media Server / Network Share?  NAS?  Give us some physical details.

By the way, until WD supports Audio Header Compression, the new versions of MKVmerge will BREAK audio on the WDTV unless you disable that feature via command switch.   That’s any version after 4.0.  


#8

Hi! Thanks for the speedy response!

I’ve tried streaming wirelessly from my desktop just using the network share then via the ethernet cable to the WDTV. Also tried copying it to my external harddrive and playing it directly from there - eiherway no joy. Am currently remuxing it into a .m2ts using tsMuxeR as i read somewhere that could help, just have to see