Ping request does not find host wdmycloud, while WDMyCloud is recognized as online in my network

I have been using the WDMyCloud for years giving team members access to folders assigned to them. Starting early last year, team members started having problems accessing the WDMyCloud (remotely). Recently I can no longer access the folders myself and now I find out I cannot access the Dashboard either.
The WDMyCloud does show up as “online” in the McAfee “My Network” window, where the device details (Linux computer, with IP and MAC addresses) appear to be displayed correctly. When I try to pin the device, the text: Ping request does not find host wdmycloud … is returned. What does the combination of these two findings mean?
What can I do to get the WDMyCloud to work again?

Thanks for your help.

I may have changed the device name from WDMyCloud to something else; at least I thought about doing so but may never have actually changed it.
In any case I did carry out the 4 s reset twice (while under power), which is supposed to reset the device name to WDMyCloud. Sofar without success.

You can still ping the My Cloud by IP address. Check the router’s admin page to see what IP address the My Cloud is using.

A 4 second reset does not clear the My Cloud device name. A 40 second reset will. See the following WD Knowldgebase article that explains the reset process in more detail and which fields/values are reset to default.

https://support-en.wd.com/app/answers/detail/a_id/24022

The 4 Second Reset will reset the following:

  • Admin Password (No password by default)
  • Network Mode (Default = DHCP)

The 40 Second Reset, also known as System Only Restore, will reset the following:

  • Admin User Name (default = “admin”)
  • Admin Password (No password by default)
  • Device Name (default = “WDMyCloud”)
  • SSH (Secure Shell) on Firmware 04.xx.xx-xxx, User Name and Password (default = “root” and “welc0me”)
  • SSH (Secure Shell) on Firmware 2.xx.xxx, User Name and Password (default = “root” no default password, new password enforced)
  • Remove all Users except Admin
  • All Share permissions (default = Public)
  • Automatic Firmware Update (default = off)
  • Network Mode (default = DHCP)
  • Remove all Alerts
  • mycloud.com account association (default = not configured)
  • Mobile app account association (default = not configured)
  • WD Sync association (default = not configured)
  • Backup jobs (default = not configured)
  • Safepoint jobs (default = not configured)

Thanks Bennor. I used the IP address as listed for the WDMyCloud device in the McAfee 'My Network" window. Using that IP address the ping request timed out.
Is there any reason to assume the router would list a different IP address than McAfee does?
I will try the other recommendations next.

Has the router been changed recently? If so there is a know issue with certain routers that cause problems with accessing the My Cloud on the local network. The workaround is to put a network switch between the My Cloud and the router.

https://support-en.wd.com/app/answers/detail/a_id/3637

The Mac Address for the My Cloud is on the bottom of the enclosure. Check that address against the those listed in the router administration page and see if the IP address has changed.

As to other causes. If the My Cloud is being used in a work environment it’s possible the local network router is configured to block access to the My Cloud. Or it’s possible the security software (like McAfee) on the computer has changed which is now blocking access to the My Cloud. If there is a IT department for your work ask them if they have changed anything recently.

We moved almost a year ago. At the former location the router used was a NetGear N-300 WNR2000. That router transmits at two channels with separate owner settable passwords. I used a longer password for private use and a shorter one for guests. That worked well for years in conjunction with the WDMyCloud device.
At the new address Fios installed a Fios-G1100 router (this is the primary router), with a permanent and long password, not handy for guests. I also needed more LAN cable plugin options in the office and used the older NetGear N-300 both as a 2nd router and as a switch.
There are already two additional switches in use (TP-link TL-SG1005D) as part of the house Cat 5-e LAN cable system. For various reasons the switches were installed in stages and the Netgear N-300 router was moved around. WDMyCloud is now connected to the Netgear N-300 but that was off and on connected to the Fios-G1100. I am not sure this is relevant but mention this to make sure you and other readers know what is and was going on. None of these two routers is on the above linked list of troublesome routers, but the Fios router could be made by any of the listed producers (no manufacturer’s information can be found on the Fios router).
Maybe to facilitate solving this problem I should simplify things, remove the Netgeat router and run the PC and WDMyCloud combination only using the Fios router LAN and wifi.

The 40 sec reset during power-up as per procedure resulted in a ping time-out.

Removing the (secondary) NetGear Router and using only the Fios router made a large difference; the IP address as displayed in the McAfee “My Network” window changed. The ping was successful and the Dashboard can be accessed.
Looks like I need to go through the entire (re)-installation.

A little detail left out. :laughing:

Whenever one uses a second router behind the first one will have to do some configuration on both the main/first router or the second router to get things to work right. Trying to run two routers, using two DHCP servers (and two firewalls) almost always introduces issues and problems with local network clients.

Generally you want only one DHCP server on the local network. So you will have to either disable the DHCP server on the secondary router, or disable it on the first router. Typically what people do is set the ISP router into “bridge” mode which disables most of the features of the first router, leaving the second router to handle the DHCP server, Wifi, firewall and other features/options.

Thanks Bennor for guiding me this far.
I was able to reach the Dashboard and enter email addresses for two users (myself +1) and created a password to allow signing in to MyCloud.com. This first time I managed to get access to the device and could open the files in the folders but there is a problem with the device security certificate.
I searched this site for fixes but did not find one. The information page instructed me to go on and refresh the page. Initially this worked. Once the files were in view the first part of the URL (https://) was crossed out and in red font. McAfee informed me that the access was unsafe.
After I signed out I was unable to pass device security certificate hurdle.
Any advice how I proceed from here?

First try disabling McAfee as a troubleshooting test. Could be McAfee is blocking access to the My Cloud. If you are using a McAfee browser add-n or extension, try disabling that and test the page again.

Usually when one gets the security warning when using HTTPS to access the My Cloud Dashboard. Use HTTP when accessing the Dashboard.

For Firefox if one gets the warning potential security risk page, they can select the Advance button. Then select the Accept the Risk and Continue button to continue to the web page. Other web browsers are similar. For Microsoft Edge select Details then Go on to web page. For Chrome select Advanced, then Proceed to wdmycloud (unsafe).

I don’t get any security warnings when accessing the Dashboard. There are no longer any problems with accessing the Dashboard. I only get these security warnings while attempting to log into the WDMyCloud to look into the files stored.
I switched off the McAfee firewall but that did not improve anything. The same MyCloud web page comes up (text: “Can’t connect to WDMyCloud”). Interestingly at the left top there is a small wheel icon next to the WDMyCloud text. When I click it allow me to manage users and the names of the two users added this morning show. I changed nothing but closed this box upon which the files on the WDMyCloud showed as the original shared folders created years ago. When attempting to open them the following errors comes up: “Internal server error. Retry your last operation. If the error persists, contact WD Support for assistance. (200006)”.
Closing this page and retrying to log in to MyCloud.com leads to the same page with HTTPS: crossed out and in red. Also, while file names are shown, they are not viewable. Instead when selected a dialog box opens to save them on my PC.
Any advise on how to proceed?

I also first uninstalled (rebooted) and reinstalled the desktop application and tried to log in using this application. After selecting the application shortcut icon, the 1st page shows up with: “Devices show in your network”. The generic depiction of the device is shown, with below it “WDMyCloud” and the correct IP address. I tried to log in using the WDMyCloud.com login link shown in the right bottom corner of this screen. It asks: “What device would you like to add?” and shows again “WDMyCloud” and the correct IP address. After typing in email and password the text “Failed to connect to the device” shows in red.
I tried this again with the McAfee firewall disabled with unchanged results.
What could cause this and how can I fix it?

The My Cloud Desktop application stopped working with the single bay My Clouds after recent My Cloud firmware updates. WD stopped supporting the Desktop application back in 2016. One is now supposed to use the MyCloud.com web portal or WD My Cloud mobile apps on mobile devices for remote access to a My Cloud.

If one is having trouble with the MyCloud.com not reaching one’s My Cloud, the first step is to access the My Cloud Dashboard (while connected to the same local network as the My Cloud) and disable Remote Access/Cloud Access in the Dashboard > Settings page. Wait a few minutes, then reenable Remote Access/Cloud Access. The My Cloud should then indicate on that page if it has made a connection. Then check the MyCloud.com web portal to see if it can access the My Cloud.

I disabled and enabled the remote access. Initially there did not seem to be any improvement. The only difference was that the same error page with text: “Can’t connect to WDMyCloud” no longer had a reference to an invalid security certificate. So that was an improvement by itself.
Attempting to log into the MyCloud.com using the original link in the WD email let to the same
red font and crossed out “https” showing up in front of the “:files.mycloud.com/ ….”.
In addition files could not be opened but could only be downloaded.
I tried the old link on my desktop that I used in the past and now I managed to log in without any problems; no longer a red font and crossed out “https”, while the files in the folders can now be read and even edited (if so selected).
Logging out and logging in again using the MyCloud.com using the original link in the WD email now also allowed a login without problems allowing files to be read.
Clearly disabling and enabling the remote access allowed this to work and what looked like differences based on login links used may not be real effects but simply reflecting the elapsed time since the enabling of remote access (updating settings in my MyCloud device as well as on WD servers).
The problems seem to have been solved.
Bennor, thanks for all your help!