PiDrive 314GB random beeps


#2

Hey there, Martinli.

Sorry to hear about the issues you’re experiencing with the PiDrive. :confused:
You’ve done pretty well with the troubleshooting, so great job! I’ll take a look into the issue and get back to you as soon as possible.

CK_WD


#3

While looking into things further would you please be so kind as to let me know if you have a lot of peripheral devices connected? If “yes”, would you please disconnect them and try again, to see if the issue still persists. If you have the option, trying out a 5V 2.5A power adapter might prove useful as well to see if more power can fix things up.


#4

I connected only LAN network cable and mmc card + this pidrive. Nothing else.
As linux distribution, I tried rasbian jessie lite and minibian. Both are lightweight linux system.

5V/2.5A adapter I do not have, so I can not check it. But real max current
for my 5V/2A is almost 1.9A. So, I think adapter is not problem

.


#5

Hi CK_WD.
Today I made small investigation.

I powered pidrive with 5V/2A adapter through pidrive cable, then I use only pidrive data cable to Rpi. Last 3rd power RPI cable was free. The Rpi was powered separately through second 5V adapter, so as result, we have powered pidrive without any additional devices.

I installed berryboot on mmc card and raspbian jessie lite on pidrive 314GB disk. Also I installed apache server. I put single mp3 file to the root of the html directory, so I can slowly read data from disk.

Result: pidrive is still beeping…

Also I recorded some beeping and also strange sound, something like head of the disk.
Any time during this record, i can browse files on linux through ssh, so hdd was not rebooted or something like this during this beeping.

  1. song is not playing
    https://drive.google.com/open?id=0BwygP2otrbtEcjdmZDcxR0R1X3c
  2. song is playing
    https://drive.google.com/open?id=0BwygP2otrbtET2QzbndWd01UQjA

Pidrive 314Gb was bought/ordered from WDStore 04/21/2016, so is almost new.

Please, give me some advice, what to do. I should have still warranty for this product :slight_smile:

Thank you
Martin


#6

Hmm it’s pretty odd that it would behave like this. I know it’s a bit of a given, but did you check if every cable has been properly connected and if there are no loose connections?

Also, would you be so kind as to post a few pictures of your setup so that I can see how’s everything connected? It might prove helpful.

Thanks in advance.


#7

CK_WD,

http://electronicdesign.com/site-files/electronicdesign.com/files/uploads/2015/06/pidrive%20fig1sm.jpg

RPi is connected like above schema with original pidrive cable. You can not connect in different ways. To the point 5 is going 10cm usb cable + power adapter 5V/2A.

Also I tried, that point 4 was unplugged and I added there new 5V adapter, so both devices are powered separately.

Result is as i wrote before, pidrive is random beeping.

Martin


#8

Hello,

i have same problem. Video how it sounds https://www.youtube.com/watch?v=IGtzaIlMgWA
The video was commented by Juan Antonio, he writes that they have an identical problem.

I was testing with USB hub with external 1.2A power supply (this setup worked for two weeks with no problems).When problem came, i connected not original USB cable with 2A external supply. Beeping decreased, now it beeps no three times three beeps, but one time one, or two times one.

In all this cases my raspberry is powered by 1A. Tested with 2A or 1.5A. The problem persists.

What is interesting, now drive connected to my desktop computer (Linux OS ) without an external power supply. No beep’s at all.


#9

@Dainius

Also, I connected pidrive to laptop, and I browsed files inside, there is no beep.

But yesterday, I formatted this pidrive to FAT32 and I copied Ubuntu 16.04 desktop edition to this drive. I used it as installation drive for my laptop.
During installation from this pidrive to my laptop, pidrive was beeping randomly again. Now I know, that pidrive is not working properly (is beeping randomly). Does not matter, If it is connected to the laptop with single usb cable or to the RPI.


#10

If it’s a RPi 3, give it a try with a 2.5A power adapter. As stated earlier if you have additional peripheral devices the 2A power adapter might not be sufficient and for RPi 3 (if you are using that device) the recommended power adapter is 2.5A.

@Martinli has approached me with a PM about this since I’ve delayed my reply. We’re currently looking into this issue and we will answer as soon as possible. However, it might take awhile longer so I can only thank you guys for your patience and I hope that while waiting we’re not causing too much of a discomfort with that issue.

By the way, thanks for the video.

I’ll get back to you as soon as possible.


#11

I have the exact same issue as described in this thread.
Raspberry Pi 2 powered by a good 2A 5V power supply with only a network cable attached to it … and the PiDrive.
Powering the Pi and PiDrive separately did not make a difference.
There is no info/error related to USB/PiDrive in /var/log/

But I have found a ‘workaround’ to make the beep go away:
Starting the bitcoind daemon which causes EXTENSIVE writes to the PiDrive, which makes me think that it has to do with some sleep/power saving state. When the daemon isn’t running and I hear the beeps, there is always write activity, hence my suspicion.

Here’s the systemd unit file for bitcoind I have created:

# cat /etc/systemd/system/bitcoind.service 
[Unit]
Description=Bitcoin's distributed currency daemon
After=network.target

[Service]
User=bitcoind
Group=bitcoind

Type=forking
ExecStart=/usr/bin/nice -n 19 /usr/bin/bitcoind -datadir=/srv/cryptocurr/bitcoin/
ExecStop=/usr/bin/bitcoin-cli -datadir=/srv/cryptocurr/bitcoin/ stop

Restart=always
PrivateTmp=true

[Install]
WantedBy=multi-user.target

But I’d rather not use this ‘workaround’ as it causes a rather high load on my system and way more writes to the PiDrive then needed.

If you want/like, I can provide advanced details about my system as I am quite proficient in Debian and thus Raspbian.
I’m one of the maintainers of the Raspbian NetInstaller with which this system was initially setup, but it is now mostly switched to (pure) Debian Testing, with bitcoind taken from Debian Sid (as it isn’t available anywhere else).
The root of the filesystem is on the SD Card (Samsung EVO 32GB) and I have divided the PiDrive into 3 Logical Volumes (LVM) which are mounted separately:

# cat /etc/fstab 
/dev/mmcblk0p1 /boot vfat defaults 0 0
/dev/mmcblk0p2 / f2fs noatime 0 0
tmpfs /tmp tmpfs defaults,nodev,nosuid 0 0
#UUID=1ef8cd13-e569-4587-9750-bf1c3519207b /var ext4 defaults 0 2
/dev/vgPiDrive1/lvVarPart       /var    ext4    defaults        0       2
/dev/vgPiDrive1/lvCryptoCurr    /srv/cryptocurr ext4    defaults        0       2
/dev/vgPiDrive1/lvNfsShare      /srv/nfs/share  ext4    defaults        0       2

HTH


#12
After @Pietje_Puk message i wrote small script: [code] while [ 1 ] do sleep 9 dd if=/dev/urandom bs=1024 count=5 of=dummy.txt done [/code] Now it work's about 20 hours and did not hear any beep after i run this script. I think that the file writing every 9 seconds does not allow disk drive to sleep or go to power saving mode. Later i will test what biggest sleep time necessary to avoid beeping.

#13

I think i found solution.

hdparm -B option:
-B Set Advanced Power Management setting (1-255)

After my system boot:

[dinux@alarmpi ~]$ sudo hdparm -B /dev/sda1
/dev/sda1:
APM_level = 128

Then i set -B value to 255

sudo hdparm -B 255 /dev/sda1

Check again:

[dinux@alarmpi ~]$ sudo hdparm -B /dev/sda1

/dev/sda1:
 APM_level	= off

All beep sounds are gone. Now it works about 12 hours with no beeping.

@Martinli can you please check this solution and confirm about beeps ?


#14

@Dainius
I can confirm, If APM_level = off, then there are no beeps.
Last week I checked value from 128-254 but this does not work. Only value 255 is working properly.

Dainius thank you for help :slight_smile:


#15

Guys, you are awesome. You’ve figured it out way before I was able to. You really did a great job without any help on my part and I apologize for not being able to resolve this for you in time.

Thanks for sharing your experience. It will definitely be useful to others who might be facing the same problem as you did.

Thank you @Dainius and @Pietje_Puk. @Martinli thanks for trying it out and sharing the feedback.


#16

Great work @Dainius :slight_smile:

from man:/hdparm :

A value of 255 tells hdparm to disable Advanced Power Management altogether on the drive

So I see this still as a workaround, better then mine, but not really a solution.
What (negative) effect will this have on its energy consumption? And the expected life-time as it will now be spinning always?

I really hope @WDStaff will see this as a (strong) hint where to find the proper solution and not consider this issue fixed.


#17

Thanks again for the feedback guys. Be sure that this will not go unnoticed.

I’ll let you know if anything comes up.


#18

I recently hooked up my PiDrive 314 to my RPi 3 running OctoPi for my 3D printer, and i also have the beeping.
As other have found, keeping the drive busy will temporarily stop the beeps, and disabling APM will stop them for good.

Has anyone found another solution ? new firmware perhaps ?


#19

Hello,

My Pi3 with PiDive 3.14 is on 24/7, raspbian 4.4.32v7-aufs, 2.5A. Just woke me up for the first time from the next room and morse code beeps are not random but 3-3-3-1. I see that this thread was idle for 66 days. Has any progress been made on a solution?

Thanks


#20

Hi, sorry for the delay. We recently created an experimental update utility that adjusts the settings of the head load/unload current profile (head load/unload occurs when going in and out of power management states). This drive FW change was fully validated on a sister product that exhibited a similar problem (different application though). We’ve ported the FW change to the PiDrive 314GB code and created a field update utility. This is in the form of a .img file that can be imaged to a microSD card and booted in the R-Pi with PiDrive attached. It performs the FW update and exits. Then the SDcard being used in the Pi before the update is re-inserted and the system should run as it did before, but without the drive clicking.

We’ve done internal validation of the utility on R-Pi hardware. We don’t have PiDrives here that exhibit the clicking so I don’t have effectivity data on the update, although as mentioned above it was shown to be effective on another product with same load/unload code and HW platform.

I’m providing a link to the utility below, but this should be considered experimental and should not be used on a drive containing important data that has not been backed up. We won’t consider it “released/official” until such time as enough users confirm field effectiveness and overall user experience with the utility.

  1. BACK UP any important data on the PiDrive prior to proceeding with below!
  2. Download the zip file from the link below to a PC where the microSD card will be prepared.
  3. Unzip the file to the PC using the 7-zip utility.
  4. Transfer the image file to a new or freshly-formatted microSD card (2GB or larger should work- I’ve used 4GB OK) using Win32DiskImager utility. If re-using an SDcard, reformat it using SDFormatter tool with options “Full overwrite” and “Format Size Adjustment” enabled. Exit the Win32DiskImager tool and safe-eject the SDcard.
  5. Insert the prepared SDcard into your Pi with PiDrive attached and connected/powered as recommended in the PiDrive product set-up instructions. Connect keyboard and monitor. Internet not required.
  6. Power on and follow the prompts. After accepting the licensing agreement, the update will execute and the Pi will be shut down. Update is complete at this point.
  7. Remove power. Remove the SDcard and replace it with the SDcard in use previously.
  8. Power on the system and confirm clicking is gone.

Link to EXPERIMENTAL update utility:

Link to Win32DiskImager:

Link to SDFormatter:

Thanks!


#21

UPDATE TO ABOVE: please hold on the field update utility above, we need to expand coverage of target FW version (the one posted above will not perform the update on some drives- just does nothing, so no negative effect if used). Sorry for any inconvenience. I’ll post a new version ASAP. Thanks.