Pictures do not create a thumbnail

I have tried the suggestions from the older postings. Hoping for a new “trick”? On Windows 10. Tried multiple browsers. Pictures do not render a thumbnail image in My Cloud. In grid mode, there is a preview of one picture, and that is a .png file and only appears in grid mode. 99% of my pictures are jpg. No thumbnail views in either list or grid.

Any assistance appreciated.

1 Like

Have you tried File Explorer? Open it up, then under Network, open up your My Cloud and the share where you have the pictures. After you have the ones you want to see choose the View tab and how you want to view them.

See example image below. Click on, tap or activate image to enlarge it.

Yes – no issue viewing in File Explorer. One of the suggestions I found was to make sure that the files were in an image view and not a list view, which they are.

The issue I am having is in a web browser and trying to view a file share in MyCloud. Have five kids around the country that are trying to collaborate on photo and video storage and sharing so thumbnail viewing, in the browser, is necessary.

Are you talking about using mycloud.com? What computers/devices do they use?

I am coming back to add this. After signing in to mycloud.com using Internet Explorer and choosing my share, Public, and the pictures I want to look at in a folder and opening that folder the below images show what I get. Click on, tap or activate images to enlarge them.

Have you check the KBA?

Changed browsers. Overnight, thumbnails appeared. Did do the steps below prior.

Life is good now.