Picture problem


#1

Hello,

I just bought my WDTV Live and I am very happy with it. However it has a strange bug: it displays pictures just fine but only for a while. After that it only displayes the thumbnails and when you try to see the picture it hangs on the waiting animation. This goes for Twonky, PS3 Media Server, Network Shares, Flickr

On the other hand youtube and movies work just fine. I realy like beeing able to see my pictures on TV .

The only workaround untill now I found is to reset it to factory defaults and redo the settings back. Then it works again for a while.

Thanks


#2

I think I have the exact same problem as you – the device hangs on the waiting animation – but this happens for me while playing music or videos. However I discovered that it only does that after failing to play a file (in my case a playlist with some entries that it can’t find). Every operation after that hangs at the waiting animation.

The strange thing is that turning off the device and then on again does not solve the problem. I have to physically unplug it and replug it. When I do that, the startup takes longer, so I guess the on/off feature is only a sleep mode, which preserve the state of the device. Thus, if for some reason the media player process has crashed, it stays crashed even after power cycling the device. Only disconnecting it truly reboots it.

This is unnerving because it happens to me a lot these days. Maybe it’s something in the 1.01.12 firmware?

I think I’ll repost this under its own topic if nobody replies… Not sure if this bug is widely known. Well, you’re not alone.


#3

Well I have a 1.01.11 firmware so the 1.01.12 is not the problem. And you are right, after unpluging the power cord or reseting to defaults the problem disappears, but it will come back shortly.


#4

Can you put the same image files in a USB thumb drive and try browsing the files? See if you can reproduce the same bug while browsing with local files.

Are you on wireless or wired network? 

How are the pictures shared? XP, Win 7, Vista? etc.

Any further info will be nice coz I haven’t seen this bug before.


#5

I will try using a usb. I am on a wired gigabit network. Shares reside on a QNAP 439 server linux based and shares are made with samba. Tversity and PS3 Media Server are also hosted on QNAP. I also have a PS3 on the network and on the same pictures using the media server I have no problem.


#6

For my part the problem arised on a wired network too, either on SMB shares served by Samba on Ubuntu, or using a media server (MediaTomb). I’ll try the same files locally just to be sure.

Edit: I’m on 1.01.11 too, the 12 above was in fact a typo.


#7

I have all my shares on QNAP 509 (Wired, 100Mbit network). I dont think it has anything to do with samba. It is most probably an invalid file type. If you are having same bug with local files on a thumb drive then something is wrong with the image itself. Therefore, it’s better if we can narrow it down to that particular file and if possible share it here for developers to see and fix the firmware.


#8

Before answering you I tried to reproduce this problem in various ways, but I think I’m converging towards the culprit.  The problem always, and only happens after I try playing the same playlist file. It is not that it contains an invalid file per se: I built other playlists with invalid file names and I simply get an “invalid file” message from the WDTV Live, without the eternal spinning ring of death.

The problem playlist contains an URL to an internet stream: http://207.200.96.229:8030 . But I also have other playlists containing such streams and they don’t cause any problem: I simply get an “empty folder” message and that’s it.

So I looked back on my computer and saw that I have in fact two playlists with the same name – but a different extension (one is an .m3u playlist and the other is a .pls). This shows up as a single playlist – or in fact folder – on the WDTV Live. This folder appears to contain two files, one for each of the actual playlist files. So I don’t get the “empty folder” message even if the playlists contain unplayable content. Maybe that’s why the player process crashes and the unit has to be rebooted.

I’ll try deleting one of these playlists and post the result here when I’ll be able to.


#9

I rerun more thourough tests on my pictures and found that the problem actually begins when using PS3 Media Server in some conditions.

PS3 Media Server has an option to take a Picasa Album as an RSS and stream pictures found in it, much like the flickr option native in WDTV Live. This is the only media server I have found beeing able to do that and it is the only reason I keep using it instead of media tomb or tversity at least untill a picasa option will be available in WDTV menu.  Well usually it works ok, but in some albums it reports more pictures than there realy are. In these albums the picture viewer seems to crash. After such a crash the player is unable to recover even after you power it off from you remote control.

So I think if something worth to be solved would be if it is possible that the viewer recovers from such an error.

Thanks


#10

In my case I checked thoroughly but changing the playlist’s filenames to remove duplicate did not fix the problem. It seems the problem can be reproduced each time the WDTV Live tries to play a playlist item which is an URL. So it has something in common with the OP’s problem – it seems that we both try to access an external (web) URL.