Photos displayed too small on UHD Smart TV


when I access the wd mybook public folder on my new samsung smart tv (“personal content”), the thumbs are displayed correctly. I pick a photo that I saved in UHD resolution (3840 x 2160 or bigger): It is displayed only in hd resolution, i.e. four times smaller - a little picture centered on the big screen. Is the wd my cloud server not able to stream photos larger than hd? Is there a solution for that problem? (Yes, I can use my computer which is also connected to the smart tv to display the photos. But that’s only a workaround and much more complicated.) Thanks for replying!

Hi there,

I have not tried this, please check on this link perhaps you can find helpful information:

Hope this helps.

The problem is most likely with the Samsung Smart TV’s DLNA client. If you do a search through these forums you’ll find that others are having trouble streaming DLNA content properly from the Twonky server embedded in the My Cloud. You may want to check with Samsung to see if there is an update to the Samsung TV’s embedded DLNA client (or the app used on the TV to view photos). Also review the link in the prior post for more possible information.

Thank you for your advice! I had already found this thread. I will try some of the hints given there.

It could also be in a file named “jpeg-scale.desc” on the Twonky server. I’ve changed it to “jpeg-scale.old” after having found this thread in another forum:
Currently, I’m waiting for the Twonky server to rebuild its database. I hope it will end in the result I’m hoping for… But anyway: thank you for your help!

I’ve applied that solution and now it works fine: