Photo Thumbnails extremely slow

I recently replaced a faulty 500GB Iomega Screeplay HD with a WD HD TV and a 1TB LaCie USB2 HDD. I immediately noticed the speed difference when displaying thumbnais of my photos. The WD unit can take several minutes to display a screen of ten thumbnails. It is fine once they have been displayed; I can then refer back to them and they display again immediately. However, if I eject and power off the HDD to load more photos etc, the thumbs are lost and I then have to go through the painfully slow process of ‘regenerating’ the thumbs.

Also noticed that after generating a few hundred thumbs, the WD unit randomly reboots itself and again the thumbs are lost.

I posted a question about this to WD Support a week ago and have had nothing back apart from the auto reply.

Did notice that smaller sized photos are fairly quick but anything around the 2MB take ages to display the thumbs.

Is this a known problem or is the processor in my unit faulty or is this just what to expect with the WD HD TV (latest firmware installed).

I currently have around 15,000 photos in various folders on the WD unit so I really need the thumbnail facility to work a lot faster.

(would also be nice to be able to have a playlist facility for photos - is this planned for future upgrade?)

Any pointers to what I may be doing wrong or faults with the unit would be great.

Have you searched the rest of the forum about this? I’d give it a try. You can also contact WD’s Technical Support by phone or email.

Note: If you got an autogenerated response, you still needed to respond back.  If you don’t respond, then your incident closes out after 4 days.  That would explain why they never got back to you.

To Contact WD for Technical Support

Hi BigMac - I have the same problem with my WDMyBook since I updated my firmware: the thumbnails displayed in my PS3 became extremely slow. Did you heard something about the solution for that? Cheers.

Any solutions? I am facing the same problem!  Thumnails are extremely slow to load on my PS3 !! I have to wait over 10 mins for 50 thumbnail pictures to load…
Please help !

Hello folks -

Any idea? My PS3 thumbnails are still very, very slow since I applied the last firmware in my WDMyBook.

Did you heard about any solution?

Thanks in advance.

This is winding me up something rotton.  I submitted this problem along with the “random reset when I’m watching a film even though I’ve told it not to auto update” problem.

On the picture thumbnail problem, I find that unless I wait for the thumbnail to come up then I get a “picture cannot be displayed” error, if I wait for the thumbnail to come up then it displays OK and it’s fast changing between pictures (which have already had their thumbnails loaded. As I run out of thumbnailed images it gives me the error.

Both PS3 and NAS are up to date, firmware wise.

The support advice I got was to turn it off and on again (!) and to turn off auto updates (which I said were already off). When that didn’t solve it, he suggested I send it back using the form on the website! Not really as simple as that as I’ve got about 1Tb of stuff on it!

I know my network is OK as it’s happy streaming full 1080p video! 

What’s going on! I’m so close to sending it back but I’m guessing I’ll just get one back with the same problem.

Before this I had an Iomega 500Gb Home media thingy that worked flawlessly, didn’t need updating when I added stuff to it, instant thumbnails, streaming video. No hassle! 

Come on Western Digital, please help.


I’m confused…  Is your problem with a DRIVE, or a WDTV media player?


Sorry didn’t make myself clear, the problem is with the drive. My point was if you have a WDTV and a WD my book world edition and slow thumbnails then don’t automatically blame the wdtv. I think it might be the drive!