Photo/thumbnail problem with mediatomb


#1

Hi!

I’m having the following problem:

Using Ubuntu 9.10/mediatomb for streaming photos/videos/music, everything works fine EXCEPT the photo-viewing feature:
Although the photos’ size and dimensions are correctly displayed in the info-bar, the picture itself is too small (centered on screen) and of a poor quality.

After searching the web I found out that the WD-box obviously can’t cope with the preview-thumbnails that are presented by mediatomb.
A strange mix occurs: the photos’ data is displayed correctly while the picture itself seems to be the provided thumbnail.

Using upnp-inspector for viewing what data is provided by mediatomb I saw that additionally to the photo itself a thumbnail is provided, too. I examined my mediatomb-database to find out that there are “two” entries in the “resources”-field for each picture, separated by the standard-field-separator (an example):

0~protocolInfo=http-get%3A%2A%3Aimage%2Fjpeg%3A%2A&size=864167&resolution=1280x852~~
1~protocolInfo=http-get%3A%2A%3Aimage%2Fjpeg%3A%2A&resolution=160x107~rct=EX_TH~

I guess the first entry is the picture itself and the second one the thumbnail.

Please:

() Does anybody know a solution to this problem?

() Is there a good-working and easy-handled alternative to mediatomb?

The best solution for me would be if WD fixes my problem with the next firmware-release :wink:

Many thanks

Gregor

0~protocolInfo=http-get%3A%2A%3Aimage%2Fjpeg%3A%2A&size=864167&resolution=1280x852~~ 1~protocolInfo=http-get%3A%2A%3Aimage%2Fjpeg%3A%2A&resolution=160x107~rct=EX_TH~

#2

jin_eld from SourceFourge/mediatomb-forum gave me this XML-Fragment (from Cidero):

<item id="1820" parentID="101" restricted="1"> <dc:title>DSCF7915.JPG</dc:title> <upnp:class>object.item.imageItem</upnp:class> <dc:date>2009-10-29</dc:date> <res protocolInfo="http-get:*:image/jpeg:*" size="1540474" resolution="2848x2136">http://10.102.15.106:50500/content/media/object_id/1820/res_id/0/ext/file.jpg</res> <res protocolInfo="http-get:*:image/jpeg:*" resolution="160x120">http://10.102.15.106:50500/content/media/object_id/1820/res_id/1/rct/EX_TH/ext/file.jpg</res></item>

Maybe this helps better than my first post.

Gregor


#3

:cry: hello? Am I alone with my problem?


#4

You’re not alone, I got the same problem. Nice debugging on your side, you certainly identified the source of this annoyance. However I’m at lost as to what to do next. The only two options I got is

  • wait for a WDTV Live update that would fix this (however I doubt it’s in WD top priorities right now!)
  • wait for a Media Tomb update that allows adjusting this

I don’t now of any other media server software on Linux that has Upnp / DLNA capabilities, so we’re stuck with MT it seems.


#5

In order to find an alternative to MT I’ve tried in the meantime gmediaserver and ushare , but both aren’t as good as MT concerning performance and usability.

Rhythmbox also seems to have some uPNP-functionality, but I haven’t tried it yet.

I found a list in wikipedia: Comparison_of_UPnP_AV_MediaServers.
Maybe I find some time to try out one or more of these.

I’ll keep you up-to-date.

Gregor


#6

No you are not alone.

I’ve a Synology NAS and my WDTV live access it using DLNA (uPnP av), it is working with no issue at all for video but I’ve the exact same issue as yours with the photos. Can only see thumbnails, file size is reported correctly.

I was first thinking it was a Synology dnla server issue and unchecked the fast browsing on it as this can solve this kind of issue but no changes.

Later on I changed my old crt TV and with my new sony (dlna compliant) I can access full size pictures using the exact same synology DLNA server.

My quick conclusion is that the issue is not on the server part but an issue with the WDTV live.

Your post, using an other dlna server just confirm this a little more

David


#7

Thanks Gregor; I think gmediaserver and rhythmbox can only serve audio. I don’t know much about ushare.

Hmmm your wikipedia link says gmediaserver serves video but not pictures. Anyway if other DLNA media servers use the same approach to serving pictures (i.e. both a thumbnail and the full picture), I guess we can pin the blame on the WDTV Live firmware.

At the current rate, I’m not sure when we’ll see this fix in a firmware update though.


#8

hello,

I’ve the same problem with the new WD Live TV and mediatomb 12.1

Is there a solution to the problem.

Does the current mediatomb svn?

has anyone asked the mediatomb-forum?


#9

I also have this problem with Synology NAS running a media server and WD TV Live as the client.  Is there a bug raised with WD for this?  Or any other thoughts on workarounds?

Synology DS210J NAS, DSM 2.3-1157

WDTV Live, 1.02.21


#10

My thought is to not use a media server – I only use net shares with my NAS (now, you *will* have duplicate thumb nails, but that’s the only drawback).