Phantom WD External Drive

I’m not picky. I’ll try anything electronic once, and would rather have bargains than matching external drives. For a while I just filled up the various drives with whatever I had available; now it’s time to sort and clean. So I have a bunch of different drives by different mfrs & of different sizes from 1/2 to 2 TB, and some powered USB hubs, and I managed to get 2 Seagate Free Agent drives on F and G, a Simple drive on H, and a My Book on I.  However, the Simple Drive would not open, and WD (not-so)SmartWare hijacked the letter, providing 439,808,142 bytes of data, including user manuals for MyBook in a wide and wonderful range of languages, despite the fact that there was no WD drive on H. I switched cables and put the Simple Drive on F, and nothing on H, but did the “I” drive slide back to H?  No, there is still a phantom WD drive on H (insert theme from “Twilight Zone” here).  In fact, I can still view the drive, and open the user manuals, using Windows Explorer. (OS is XP Pro on a Dell Dimension 2400.)

Any suggestions? I still have more drives, and more USB ports, but I already have an old and unusable CD writer on D and would just as soon not have any more phantoms.

TIA, Bytten

The SmartWare Virtual CD on our My Book and My Passport drives is easily disabled using either SmartWare or the Virtual CD Manager.   I would probably do that first of all if you do not need SmartWare and are not using the password locking feature of your My Book.

To disable the Virtual CD in SmartWare, go to the Settings tab, then click on Set Up Drive and Virtual CD.  If you do not use SmartWare, then you can use the standalone Virtual CD Manager instead, which you can download here:

http://www.wdc.com/wdproducts/wdsmartwareupdate/utilitiesstep1.asp?id=wdfMB_Essential&os=win

Disk letter assignment in Windows XP and higher is arbitrary.  You can use Windows’ Disk Management tool to reassign letters:

http://support.microsoft.com/kb/307844