Perplexing issue

First a little history. Bought 2 500GB Caviar Blues from New Egg. Within the direct return period, I had to replace one of them. A day after the period ended the other HD quit. After calling customer service, they allowed me to return it back to them for another new HD. I attempted to install it 2 weeks after receiving and it was DOA. I then got an RMA from WD and sent it in. In return, they sent me a 750 “recertified” Black. I went to install it today and it showed as DOA. I had also unplugged the 500GB (data backup) that was working when I tried this. I hooked up the data and power plugs back to the 500 and it doesn’t work now. I suspected my SATA ports were toast, so I tried both drives in another computer and neither are seen in BIOS, where as the original SATA in the other computer is seen when it is plugged back in.

This has me stumped. I highly doubt I am getting this many bad drives. Any ideas on what I may try?


AMD Athlon 64 4800+

Win XP Pro SP3

Dude, if I were you I’d try to contact WD again and instead of going for a replacement I’d try to get in touch with a senior/advanced tech for a second opinion, this is just extremely weird.

That is exactly what I plan to do tomorrow once they are open. No way can this many drives fail unless WD has some serious QC issues. Being I have always used WD, I doubt that it is the case. Thank God my trusty 350 GB EIDE is still going strong.

As an update, I updated my BIOS and Chipset. I also tried the jumpers on pins 1 & 2 as mentioned in another thread with similar issues. Neither worked.

“DOA” and “doesn’t work” don’t tell us much at all. Do the drives, both old and new, spin up? Have you tried the OPT1 jumper (pins 5 & 6) on your new drive? This jumper restricts the SATA interface to 1.5 Gbps.

Both drives spin up. Neither Windows XP (Drive management) or the BIOS see the drives. The old (new) 500GB drive was working before I unplugged it. I just tried the jumper for OPT1 as you suggested (even tried it on the old one), and neither show up as being installed. I could see the original and replacment 500GB drives. I had one setup as a clone of the EIDE drive and the other I ended up splitting into two partitions after I had to swap back to the 350GB EIDE drive. One was for data and the other was for backups using Acronis Home Edition.  The later one mentioned is the drive that I still have and is no longer seen by the system. As I mentioned eariler, I have also tried these drives in another computer and it doesn’t see them either.

EDIT: I have also tried another set of new data cables to see if that was the problem.

It does appear that you’ve been very unlucky. :frowning:


MHDD can communicate with a drive without going through BIOS. I suspect that it will report that the drive is BUSY (BSY). You may need to configure the SATA controller for legacy or IDE compatibility mode.


Never heard of that program, but will try it. If it shows them as busy, is that good or bad?

After you apply power to a HDD, its MCU (microcontroller) performs some self tests, including a check of SDRAM and flash memory. If all is OK, it then commands the motor controller to spin up the drive. Once the motor comes up to speed, the MCU then accesses a reserved System Area (SA) on the platters. The SA contains the runtime firmware and other data that are required for the operation of the drive, eg ATA commands, SMART data, LBA-to-physical-sector translator. After accessing the required code modules, the drive should come ready (RDY). If it remains BSY, then something is wrong.

Thanks. I do have some dumb questions before I try this. What commands do I do to let it talk to the drives in a manner that will give what you say? Also, should I try only one drive at a time, or can I hook them both up at the same time?

Sorry, I lost track of your thread.

Anyway, here is the MHDD manual:

Thanks! I will read through it.