Permissions Limitations

Maybe I’m just dense, but is there really no way to make read only public shares?

No way to make hidden shares that can only be accessed via a trailing $?

And how do the username and passwords work?  It seems if you navigate to files through a drive mapping you can’t just punch in the username and password.  I assumed you needed to lead with the local machine name of the EX4100 (EX4100\Username) but that doesn’t seem to work either.  Are you required to use a WD application to access it?

Is there any way to create an “everyone” or “guest” account that can be used to access shares with read only and without a prompt?

These seem like very basic NAS functions and I’m a bit baffled that they could be missing.

Hello,

Regarding the public shares; There’s no option through the standars procedures that allows you to change the permissions on that share.

Regarding your questions:
Question:  No way to make hidden shares that can only be accessed via a trailing $?

Answer:  Correct, there’s no way to create a hidden share without essentially hacking the smb.conf file that won’t survive a restart of the device or an update of the share settings.

Question:  How do the username and passwords work?

Answer:  well… that depends, are you joined to a domain?  If so, then that may be your issue.  With the latest firmware of the EX4100, I am running into an issue where I cannot access private shares using AD credentials.  it’s just NOT working.  

That being said, if you create a local useraccount on the device, and then access the share from your endpoint, it SHOULD challenge you for credentials…   once you enter them, you’ll have acces… 

Hope that helps, 

Peter

Tengu wrote:

Regarding your questions:
Question:  No way to make hidden shares that can only be accessed via a trailing $?

 

Answer:  Correct, there’s no way to create a hidden share without essentially hacking the smb.conf file that won’t survive a restart of the device or an update of the share settings.

 

Question:  How do the username and passwords work?

 

Answer:  well… that depends, are you joined to a domain?  If so, then that may be your issue.  With the latest firmware of the EX4100, I am running into an issue where I cannot access private shares using AD credentials.  it’s just NOT working.  

That being said, if you create a local useraccount on the device, and then access the share from your endpoint, it SHOULD challenge you for credentials…   once you enter them, you’ll have acces… 

 

Hope that helps, 

 

Peter

Question:  No way to make hidden shares that can only be accessed via a trailing $?

Answer:  Correct, there’s no way to create a hidden share without essentially hacking the smb.conf file that won’t survive a restart of the device or an update of the share settings.

Answer: yes, modify the /etc/samba/smb.conf files where browseabel = yes, change to browseable = no.  If system restart the setting will change back to yes.  I forgot where to go to do a permanent change.  Still tune, when I go get a drink and come back with an update for the permanent change.

jebusx wrote:

Question:  No way to make hidden shares that can only be accessed via a trailing $?

 

Answer:  Correct, there’s no way to create a hidden share without essentially hacking the smb.conf file that won’t survive a restart of the device or an update of the share settings.

 

 

Answer: yes, modify the /etc/samba/smb.conf files where browseabel = yes, change to browseable = no.  If system restart the setting will change back to yes.  I forgot where to go to do a permanent change.  Still tune, when I go get a drink and come back with an update for the permanent change.

Thanks for the reply & am looking forward to the update and the information on a permanent fix for this!!  

Regards,

Peter