Permissions issue

I have written a straightforward robocopy script to perform incremental backups on demand.

When I run the script I am receiving: “You do not have the Manage Auditing user right.”

I have gone as far as giving Full Control of the MyCloud drive to Everyone, but nothing seems to allow the script permission to copy the files.

This is Win 10 fully updated, 4TB MyCloud fully updated and connected to router by NIC, MyCloud drive is mapped to PC.

I may be missing something obvious, but research hasn’t been helpful so far.

I would appreciate any guidance and suggestions

Thanks all!

Are you running Robocopy from an elevated command prompt?

Right click on the Windows icon and select “Command Prompt (Admin)”.

I will try that but, as the script is a .bat file on the desktop and I have run it as Admin, is that not basically the same effect?

Thanks!

No its not quite the same. Windows still places some user access control (UAC) type restrictions even on accounts designated as Administrators when it comes to running certain programs or shortcuts. Microsoft does so to prevent even Administrator accounts from running scripts/programs that could harm Windows. Often one can bypass the UAC or similar restrictions on certain shortcuts by changing the shortcuts advanced properties to run the shortcut as an Administrator.

1 Like

Thanks Bennor - I finally figured this out.

Rather than permissions, it was one of the flags on the robocopy command.

I’ll detail here in case someone in the future runs into this:

There is a /COPYALL flag which copies the file and ALL info.

You can also set different flags on the copy command as follows:
/COPY:copyflag[s] : What to COPY (default is /COPY:DAT)
(copyflags : D=Data, A=Attributes, T=Timestamps
S=Security=NTFS ACLs, O=Owner info, U=aUditing info).

/COPYALL is the same as /COPY:DATSOU

By changing my flag to /COPY:DATSO, I prevented the Auditing info from being part of the process and the script runs fine.

Again, thanks for your input!