Permissions issue with SMB

All of a sudden I am unable to access some of my shares via SMB.This happened after resetting the system settings using the dashboard. I have given my user account full permissions in the dashboard and am able to open the share fine. However when I try to open any folders inside the share it says I don’t have permission to view these contents. I have tried the fix in here:

though it does not seemed to have helped. I’m not sure if it’s related or not but I also have lost my admin account entirely and one of my user accounts now seems to have become one. I tried reseting with a paper clip which let me bypass the login screen entirely but still no admin account. I can live with this but not sure if it’s related or not to my permissions issue

The problem also seems to be affecting some shares and not others?

I have SSH if that helps

I would recommend a full factory restore from the Dashboard. Please note this is a data-destructive process and all stored data will be erased. If said procedure does not address this behavior then maybe you should try contacting WD’s Technical Support about this. You can do so either by phone or email.

To Contact WD for Technical Support