Permission Problem with SyncToy

Hi all,

I’ve got a problem with my WDMyCloud (2TB) NAS. I have 2 computers (with different users) which sync a local folder with the same network share by using Microsoft SyncToy 2.1 (to keeps files on both hosts in the latest version). However, after the first user has synced to the share on the WDMC, the other user cannot overwrite any files with updated versions. I have set full file access for both users in the WDMC’s web-interface, and have also tried setting the share to public access, but to no avail. I have logged into the WDMC by ssh and verified that both users are in the group “shared”, and I have also entered both of them in the group “administrators”, but no success here either. The funny thing is, I can open any file on the remote share from any of the two hosts and change any file directly (e.g. by editing), it just doesn’t work with offline changes applied by SyncToy. I am not doing anything different to my old NAS, where everything worked fine, so it seems to be a peculiarity of the WDMC.

Does anyone here have an idea what the cause of the problem could be?

Hi, I personally have no experience with this software, maybe some of the other users can give you some advice. You could also look for more info on this on the SyncToy forum.