Permission Issue at My Book Live

I got a new My Book Live 1TB production and update the firmware to latest version, but I encounter a problem while I setting up Remote Access.
I can use internal IP with URL  http://Internal-IP:80/UI to access WD management page, but when I use a external IP to access it, it told me ‘Forbidden’(HTTP 403), the web page contents is:

You don’t have permission to access /UI on this server.

The version of My Book Live firmware is: MyBookLive 02.10.09-124 : Core F/W, note that before I update my firmware, I can access to WD management page with external IP normally.
I searched some information about this issue, most of people said that this is a bug in latest firmware, I tried to enable SSH and rename .htaccess file under /var/www/UI but this issue still cannot solve.
Could you please help me solve this issue?
Many thanks.:smileyvery-happy:

I don’t think it’s a Bug.   I think it’s intentional design…

Opening your Web Dashboard to access from the Internet is significant security risk, so they turn that off.

Open my Web Dashboard to access from the Internet is allowed and it should be decide by users not WD, and I also unable to access to FTP with external IP, do you think this is a intentional design as well?

No, FTP works fine from the internet.

I checked again, my FTP server is ok but I must use ftp://username:password@MyBookLive/ to login to FTP server.
If I use ftp://MyBookLive/ to access, there will cause an error: Windows cannot access to this folder.
That’s why? Please help me!

It’s possible to change the firmware (Debian Linux) to remove this limitation:

To enable SSH access to the NAS, go to this page: http://your_mbl_address/UI/ssh

In the file “/etc/network/if-up.d/local-net”, comment the following line with a “#”:

      # echo “Allow from $LOCAL_NET.” >> “${TMP_ALLOW_FILE}”

and add the following line:

      echo “Allow from all” >> “${TMP_ALLOW_FILE}”

Then run the script “/etc/network/if-up.d/local-net” to apply the change.

This change should persist over time and reboot. Maybe a firmware update will require repeat the procedure.

P. S. Use “nano” as a text editor