Permisions/owner/group changing on External usb drive on My Cloud storage

Product: wdbctl0040hwt-NESN (My Cloud 4TB)
Firmware: v04.00.00-607

External USB drive: WD My Book 2 TB USB 3.0 Hard Drive with Backup

The short story.  I ran out of disk space for the 4TB MyCloud drive, so I ordered a 2TB to add to the MyCloud device.
I copied over the files from the internal share over to the “external” 2TB share, and then noticed that the owner/group/perms changed.  This doesn’t happen on the internal shares.  My goal is to configure the My Cloud device to ensure that none of the shares data have their owner/group/perms changed, and the config persists after reboot’s or firmware upgrades.

After I fixed the perms on the USB share, expecting the owner/perms to change again (and they did), I ran “top” and noticed this process was consuming substantial cpu time:

root       412  8.7  0.0      0     0 ?        S    Jul17 481:40 [usb-storage]

I am wondering if it is doing the permission changing on the usb drive?

Here is how the usb drive is mounted:

WDMyCloud-1:/shares/MyBook2TB1# mount | grep MyBook2TB1
/dev/sdb1 on /var/media/MyBook2TB1 type ufsd (rw,relatime,nls=utf8,uid=65534,gid=1000,fmask=0,dmask=0,force,user_xattr)
/dev/sdb1 on /nfs/MyBook2TB1 type ufsd (rw,relatime,nls=utf8,uid=65534,gid=1000,fmask=0,dmask=0,force,user_xattr)

It looks like some process, using the mount params uid= and gid=, is ensuring that the owner/group are set to these values.

It may be that I don’t want the default uid/gid set in the mount options, and since the perms are changing, probably don’t want fmask, and maybe some of the others?

I remounted the USB as follows:

    mount -t ufsd -o rw,relatime,nls=utf8,user_xattr /dev/sdb1 /var/media/MyBook2TB1
    mount -t ufsd -o rw,relatime,nls=utf8,user_xattr /dev/sdb1 /var/MyBook2TB1

Then checked the mount:
WDMyCloud-1:/nfs/MyBook2TB1# mount | grep MyBook2TB1
/dev/sdb1 on /var/media/MyBook2TB1 type ufsd (rw,relatime,nls=utf8,user_xattr)
/dev/sdb1 on /nfs/MyBook2TB1 type ufsd (rw,relatime,nls=utf8,user_xattr)

Then I updated the owner/group/perms on the external USB device, and now it seems that the owner/group/perms, are not changing.

Is there a way to ensure these owner/group/permission values are not changed for my usb drive via. the web interface to the MyCloud device, where a reboot or a firmware update won’t just revert back, changing all the perms to the mount defaults?  I am willing to try formatting the USB to something else if that will help.

Thanks muchly!

If there is a way, then it’s likely related to SSH. Hopefully you will be able to obtain the information you are looking for.