Periodic Access to Folder structure / No access to data

I have a 500GB passport drive that has been out of action for a while, although with previous broken drives I have  a feeling there is still some life in this one.


Cannot access any of the data on the drive. Currently approx 250GB of content.  

When i plug the device in to a computer (tried mutiple ports, cables and computers) the results are intermittent.  Sometimes the computer will pick up the USB device, beep and fill fire up the autostart software (smartware on the e:). An F: drive will then appear, but when clicking on it windows asks me if I want to format the drive  (i’ve tried to format the drive, to see if it corrected trhe problem and was then planning to recover with Norton, but the format feature first tells me the drive is in use by something else and then the format fails.)

If accessed via disk manager I can also view the drive, that states an online health primary partiion.  Via disk manager I can right click and explore the drive. This however only allows me to click though some of the directory structures.  Some folders open and allow me to browse around others don’t and it hangs.

I can’t however open any files from the drive, which cause the exployer window to freeze or copy anything onto the computer or another external.

I’ve tried a couple of disk recovery utilities, but they have had issues accessing the drive.

Any suggestions how to copy off the data  or fix the issues?



You can use Recuva or Photorec to recover the information and then write zeroes to the unit with the Western Digital DLG application. You can download from

Thanks for the reply.  Unfortunalty since i posted the initial description, the scenaro has changed a little.

I was able to copy off a few folders of pictures and deleted a lot of the data I didn’t need, but now the drive throws a differnet error.  It periodically appears within exployer when the drive is connected and when i click on the drive it throws an error;

F:\ is not accessable

The Parameter is incorrect.

This happens either via exployer or disk manager.  I’ve tried using the two recover tools you suggested but both throw the same error when trying to access the F:

The DLG app you recommended i downloaded and ran the full diagnostic that took a few hours, but everything came back positive with no errors.

Any other ideas?