Performance goes to almost nil when I connect external drive

I’ve tried everything from simple restore to full restore.  My firmware is up-to-date. I’ve confirmed the external drive (WD 1TB Passport drive) has correct disk permissions and has no problems.  I’m running iOS 10.9 on a MB Air.  I have a Belkin router with uPnP enabled.  I called tech support last night and got no help just, “Looks like you’ve tried everything.”  The performance is fine until I connect the secondary drive.  Then I can’t do almost anything.  The web interface times out before connecting and the Finder window takes 30-60 seconds to switch between folders.

Is anyone else facing this issue or do I have a lemon?


Also, can I go back to the previous firmware version?  I have a feeling the problem started when I updated the firmware.  Or not, but I’d like to try it.

It could be that MyCloud is scanning the external drive for media content, this usually consumes a lot uf CPU power (there’s a separate indicator called “Content Scan” for this on the dashboard (bottom right corner), if it is not scanning it should display “Idle”).

If you don’t want to serve media (DLNA) from the external drive, go to the Shares section, and disable “Media Serving” for the external drive, unplug the drive and plug it in again. If you want to serve media from the external device just let it run for a view hours until it has indexed everything.


Each time I’ve connected the external drive I get an alert email telling me My Cloud has stopped scanning for content.  Not sure if that means anything…

Same thing here.  I’m on Windows 7 and connected a 2 TB WD Passport Ultra.  I can see files on the external drive but I can’t write to it and the dashboard is unbelievably slow.  If I unplug the drive, everything works fine.  I haven’t tried disabling media scanning - I’ll try that this weekend.