PC and BIOS can't detect my new WD Caviar Black

Problem with the following Drive: Western Digital Caviar Black (WD1502FAEX) 1.5TB SATA3 7200RPM 64M Cache (OEM)

Here’s the full process of what happened:  

  • Boot new PC with SSD and HDD inside, windows installed to SSD, everything works fine.

  • Started downloading some files, and realized that my WD Drive wasn’t detected in ‘Computer’

  • My brother informs me that I have to format the drive for it to be detected, so I go into Device Manager and try to do it. I believe I did this correctly, since after a minute my E: drive (HDD) now appeared in ‘Computer’.

  • I immediately start copying / installing programs to E:.

  • A couple hours later after rebooting, E: no longer appears in ‘Computer’ so I go back to thedevice manager, and it no longer exists there.

  • I tried unplugging and replugging the HDD many times with different SATA connectors, always the same result.

This is what my BIOS displays under SATA CONFIGURATION:

SATA Mode - AHCI  

S.M.A.R.T. Status Check - Enabled  


Sata6.0 1 - 0.00 GB                                       (This should be where my HDD is detected)                   


Sata6.0 2 - M4-CT128M4SSD2 128.0 GB        (this is my SSD which is detected)                    


then the 4x unused sata drives:  

Sata 3.0 - Not Present                  


It seems to see that theres something in the 1st SATA port but doesn’t properly detect my HDD. I bought it 2 weeks ago, and never used before this issue, do I have to RMA it?

I’m using a ASUS P8P67-M PRO MB if it changes something.

I don’t know to much about this but sometimes the port for the system drive needs to be in a certain port. Check your MB about that. You might need system drive in port 1 then other drives after that. Did you add the SSD then swapout the old drive for the new one?


Just for fun, try taking the SATA data cable from the SSD and try it with the WDC Black.  I would even try it in one of the SATA II ports on the motherboard.  If you have another system, plug the drive in it and see if it reads.  Can you please post some pictures for reference?  Thank you in advance!

I have the same problem with my velocity raptor wd4500hlhx.

When it was formatted it was easely detected by bios, but after i installed a system on it and reboot it dissapeared from bios.

I use ICH9R in AHCI.

my MB is Asus maximus extreme (LGA775)