PC able to access password protected non shared folders


#1

Hi there,

I am in need of help that anyone can offer.

Here is my problem:

I am running 2 macs and a PC all accessing MBL. On the MBL I have folders (discs) that are for me (1 mac and the PC) and folders that are my wife’s on the other mac. They are mounted discs that are password protected and when using the macs I have no problem, but when I use the PC the list on the side (favourites, libraries and computer) the computer lists all the drives and I can access my wife’s. If I go to network and click on MBL it is password protected as it should be. I guess the question is are there any settings on my PC that I have missed so that I cannot access my wife’s drive inadvertently? I know this is a funny request but I should not be able to access the files on my wifes password protected drive.

Thanks all in advance

Dave


#2

As far as I know, the way the shares are setup is that users have varying access rights to shares and the shares don’t have passwords but users do. If you mapped the folder using a user that has access to your wife’s private share (like admin) you will have access to her private share. Also if a private folder has media serving enabled you can access the media from a DLNA device without a password (not sure about this). And everybody has access to the default public folder. Also if you know the admin password you can always gain access to everything.

So in summary you have shares which can be set to private or public. Then you have users which have passwords and they can be given read only, read/write or no access to desired shares. What you should do is give the user you are using to mount discs (=map network drive) on a computer no access to your wife’s private share (Can be done either under Users or Shares menu) and turn off media serving for all private shares. I hope this helps.


#3

Contagious,

Thank you for your response and that solved it. I turned off media server for my wife’s disc and then re-booted my PC and now it doesn’t list it in the computer list (it was listing discs all the way to z: which was kind of strange. I tried accessing all discs from all laptops and it is correct now.

Thank you again