Pausing RSS video feeds - bug?

I added an RSS feed of an HD show and it streamed/played but pausing does not work. I even plugged in the keyboard and pressed the space bar. The progress bar went from play to pause but the video kept on playing. 

Is this a bug?

Don’t know if is a bug, have not tried it myself or find more users with the same issue.  You may update to latest fimrware and also reset it.  If issue not resolved you may contact WD for support.

thanks. One thing I’d like to see is public access to a bug database with ability by the users to submit butgs. 

There is precedent. For instance I use a cloud based storage servce by Lacie called Wuala and they allow their users to submit bugs

Having someting like that would allow for the users to see what is being worked on, priority etc. I’ve not seen any downside to doing this from a buisness side. It works and people are happy to see bugs in an official repository instead of down some big hole not knowing if their bug was just ignored or not.

Wuala uses MantisBT, but other systems could be set up this way as well.

WD uses the issue reporting system here: