Password Problem and Question

I know very little about computers and even less about networking.  I received a 3tb My Book Live for father’s day.   I have one problem and one question that I was hoping the forum could help with.


I installed the MBL on Sunday by connecting it directly to my router.  My computer is a desktop running Windows 7 x64 - Home Premium and connects to the router wirelessly.  I installed the WD software on the desktop and used it to update the MBL firmware.  Afterwards, whenever I tried to access the MBL through explorer, Windows asked me for a user name and password (I never set a password/created users etc.).  I uninstalled the software, and voila, I could access the drive again.  So I began dumping files on the drive.  This morning, I tried to access the MBL (never reinstalled the software) and it asked me for a user id and password again.  In Windows explorer there is a red “X” on the MBL drive icon and is says disconnected.  I can still access the files on the drive  from my ps3.  What is going on and how do I fix it?


As far as transfer rates are concerned, how much faster would it be if I connected the MBL directly to my desktop with a cat5 cable (vs the current connection of MBL to router with Cat5 to computer via wifi)?  If it’s faster, once I have transferred the files, could I connect the MBL back to my router (I don’t want to have to leave my computer running).

Your helps is greatly appreciated!

With a public share, when Windows asks for a UserID and password, just provide random info; it just won’t accept “Nothing.”

So for example:

Username:  guest

Password:  guest

should work.

Thanks for the suggestion but unfortunately that does not seem to tbe the issue.  I’ve tried many combinations of user id and passwords - nothing works.  I’m not sure what I’m doing wrong or if there is a way to turn off the password security?

As an update, when i got home this evening the MBL was available and I was able to dump more files on it.  After about two hours, however, it reverted back.  It says it is disconnected and windows requires a password for me to access it.  No combination of user name and passwords works.  I only have one public share and one user in quick view.  I have not assigned a password to the user profile.

Any ideas?  Please help.

What Windows 7 does is to anonymously log-in to the MBL.

When you can’t access your private shares, try this… Open a command window and issue the command:


After that try to connect to a share that requires a specific user name and password.

This issue is covered in detail within other discussion threads.  If you search the forum for the command I’ve given you should find those threads.  This issue affects just about every make and model of NAS on the market.  Unfortunatly it’s a Windows XP, Vista and 7 annoyance.

For someone I help I created a batchfile that went something like . . .

NET USE * /DELETENET USE H: \\MyBookLive\SomeShare /USER:SomeUser *

That terminates all logged in connections and reconnects with the closen login.

The issue is that if the client supplies a username that is not known to the NAS then the Samba service logs that client/user in as a guest.  Something I’ve not examined is if it is possible to conguigure the Samba service (that the MyBook Live uses) to reject guest logins.  This is the default conditions with Windows operating systems.  To get a Windows operating system to behave like the MyBookLive, find the guest user on the computer and enable it.  :smiley:

I had a similar problem. I have little knowledge of networking but this worked for me.

Go to dashboard and set password. When the windows requester pops up type \admin for user name (if using the default). And the password you set up.

Good Luck