Password for Public

I have a My Book one TB Model WD10000H1NC-00 on a local network. The drive folders are all  accessible by a desktop and a laptop on the same local network these two computers are running Vista. A password is not required.

 A Windows Eight laptop has been added to the network. The folders are all accessible except Public. It is insisting on a password. The WEP password does not work. And I have tried all other passwords associated with the Windows Eight machine.
 I see no difference in the security settings for Public as compared to the other folders. I know that I have the correct user ID via DOS cmd prompt Net User.
Any Suggestions?
Frank C

My stepson, Steve pointed me to the folder permissions in the WD external drive as the culprit.
I never would have suspected the WD disk permissions to be the problem.
I found the IP address for the WD External drive with Netstat 60 -a -f -n -o. I looked at the ESTABLISHED Foreign Connections and tried Using a browser, that IP got me to WD login  I did have the Admin Name and Password
From there:
Users > Folder > Share Permissions > Public > Modify > Full access > Enable
The Public folder  permissions were different from the other folders.
The Windows 8 laptop now has access to public without a password!

Frank C