Passport wireless 2tb not appeareing trough USB nor wifi

It shows up in device manager only. In disk manager shows as unallocated, it asks for initialise disk. tried to do it with MBR and GPT,both ends with error message the request can not be performed because of I/0 device error. I managed to update to new firmware but no help.

Trough browser and wifi same thing. Disk doesnt show up. I can hear and feel it spinning though but cant access my files. Tried different cables different computers ports. all the same.

Any idea how to access my files.


I/O Error is normally related to an issue with one of the connections. Have you tried connecting the drive with a USB cable directly to the computer?

Also, you can try the unit on a different system. If stills the same, please try contacting wd support for direct assistance.

i tried different cables 2.0 usb only. on different computers. no avail. disc doesnt show through wifi either. everything else works even SDcard reader on disc just no HD and data.