Passport USB 3.0 Drive, MP3 Analyzing, Varied Speeds

I have a 1TB WD Passport (bus powered) and a 4TB Seagate Backup Plus (externally powered). I’m using them on a Windows 8 i7 x64 computer.

When I analyze tracks through my DJ software (Serato DJ, and also Scratch Live) on the Passport, the disk speed is decent and CPU pegs to 100%. After 14 tracks, disc/cpu slow right down to under 10% and vary up to 100% again, however inconsistently, until finished.

When I analyze tracks on the BP, everything operates beautifully, without issue.

I’ve found a few threads on the Serato forums about USB 3.0 issues, some suggest updating iusb3mon, which I wasn’t sure how to do. I ran the the Intel utility which updated some things here and there, but USB wasn’t any of them. I should note that my Asus mobo requires a Renesas USB3.0 Controller Driver (V2.0.4.0), which is installed.

I updated the Passport firmware (was 1.042, now 1.049) (even though none of the release notes had anything relative to the issue) and am still having the problem.

This behavior also happens on my work laptop, also USB 3.0.

My USB 2.0 Passport ran fine during analyzing, and that was bus powered.

I ran the WD Drive Utility (Extended test) and it passed with no bad sectors.

I called WD Tech Support, which wasn’t too helpful until I asked to be escalated. The final person I spoke with took some notes and advised that it is being passed on to R&D and also suggested I share my experience here.

Has anyone run across this sort of behavior?

My recommendation is to update the USB 3.0 drivers on the computers although it works fine with one software and not with the Serato DJ.

Other thing that I can think of is that the software is not buffering the files properly.

Have you tried reinstalling the software?

All of the USB 3.0 drivers are up to date, and I’ve even rolled back to verify that it’s not an update issue.

Why would the software not be buffering files properly on TWO seperate computers with just the WD drive? The Seagate USB 3.0 drive handles everything fine.

I have uninstalled and reinstalled the software, but again, as I mentioned in my first post, this is happening on multiple computers with just the WD drive.