Passport upgrade to pro

I hope someone from WD reads this!

Bought my passport 2 years ago.

I have just paid for the upgrade to pro and bought an activation code which does not work when i enter it.

It tells me to try later. I don’t want to try later as i have paid for a service and expect it to work!

I also tried to update the firm ware but could not do this either.

I have made sure i have put the activation code in without the drive being connected as suggested…i also tried with.

I have contacted WD and set up a case…case number [Deleted] so much for the reply within 24hrs by the way.


I have the same issue that has lasted for 2 months so you are not alone. I have passed it to WD support and tried all they have suggested and still do not have a clear.

did they charge your card?

If this hasn’t been resolved in a few days i will be asking for a refund…i feel like asking now on the grounds of “not fit for purpose”

Almost 48 hrs no reply to opened case.

Have you tried the following that I posted yesterday. So far it has worked for me

Not sure if this going to work but I went to this site and regitered my activation code?

I will let you know how long it will work