Passport Studio Mac not detected after failed firmware upgrade


My WD Passport Studio for Mac can no longer be detected after the mac firmware upgrade process failed, I have tried to unplug and swapped from USB to FireWire and back, ran the upgraded again, it’s now stuck at detecting the drive. the virtual cd is no longer mounted now… Restarted my Mac a couple of times too.

it also does not get recognized when I plug it into a windows pc, even with the SES drivers installed. FYI, I have encrypted the drive with a password. As I have a lot of important and sentimental data stored in it, is there anyway to recover the data?

in the case of a RMA, can I request for the drive to fixed instead replacing it? I believe this is just an issue with the drive in firmware flashing mode and it just needs to be restored to the functonal state.

Appreciate your kind advice.



What software did you used to protect the data?

Have you tried with a data recovery software?

1 Like

I used the default SmartWare VCD encryption, can’t do any data recovery since the drive is not even recognised…