Passport Studio 320 Firewire 400 problem under Leopard


#1

I need to transfer large files between Macs (home and office) using either Firewire 800 and Firewire 400 so bought a WDPassport Studio. However, the drive will not mount using Firewire 400. Will work using 800 or USB. My Macs are running Snow Leopard and Leopard, some are intel some are G5s. Drive will not mount on any machine for Firewire 400. Took it back to place of purchase and they also found the same problem for firewire 400. Have not tried it under earlier systems. Does not seem to matter whether i have WD drivers installed or not. Reformatting the drive did not help.


#2

1.  is the drive spining with 400 connection?

2.  if yes, do you see the drive under system profiler?

3.  if yse, what is partition and format under disk utility?  MBR, GPT, or APM?  HFS+J or FAT?


#3

Answers to questions:

Starts to spin then stops.

Not visible under system profiler or Disk Utility

Drive formatted as from WD.

The situation is worse than first reported. I cannot get it to connect to Firewire 800 either.  

This is the second drive of this type for me in the last few weeks. The first failed after about 3 days and I took it back to the place of purchase and they exchanged it. Since first reporting the problem I took this drive back and they said it worked with Firewire 800. They did not have a Mac that did Firewire 400 to test that. So I took it home again.

At home I connected it up to my Macs at home and could not get it to work with Firewire 400 or 800 across a range of Macs (iMac intel, G5 tower, G4 tower). Both the towers have Firewire 800. Took it to work and could not get it to connect to Firewire 800 on a new Intel 24" iMac.

The same thing happens each time. The drive goes in and it starts to spin up then stops dead. Plug it in to USB and it is fine. The Firewire ports are OK as they work with other drives (LaCie, WD MyBook, Blue Eye). It is not a cable problem as I have tried other cables and also got other drives to work with the cables.

I also tried piggybacking it to a WD MyBook using the second Firewire 800 port on the WD MyBook. It immediately cause the WD MyBook to be removed from the desktop producing a device removal error. Take the Passport drive off the piggyback and the MyBook reappears. Did this a few times and the same thing happened each time.

It does also not seem to matter if I have the WD drivers installed on the Mac or not. I also updated the WD drivers by downloading the latest drivers. No effect.

I also tried using the USB connection to reformat the drive to MS-DOS Fat and Mac OS Extended (Not journaled). No effect.


#4

I just purchased a 320GB model as well and am experiencing firewire 400 transfer problems as well. The drive simply becomes unresponsive when transferring large files. Did you find a fix for this problem?


#5

No problem persists. I am under the impression that their is a problem with the Firewire card in the drive as USB is fine. The drive does not seem top get enough power to mount.  I was hoping that the 10.6.3 update would fix the problem but no luck.