Passport not showing on my mac

I plug my passport into my mac (original format) and the light comes on and i can feel it working in the passport but nothing shows up on my mac. i tried it on two other macs and still have the same problem. it was working fine one second then i ejected and a few mins later it wasnt working. Im worried because my passport is full of important work. i have read people having issues after dropping their passports etc but i never have. thanks guys 

Have you tried a different USB cable? They also make a power booster cable if it’s a power issue.


I have the same problem: got a WD passport that doesn’t mount - it is visible in the “Disk utility” tool on my mac - but not in finder

i have put a tread on this forum, but no help:(


I have got the exact same problem! I do not know what to do.

Ill try to open another Post, but if someone knows how to help us, you might help two for the price of one :wink:


Thing is, you guys might have different reasons as to why it’s on DU but not working…

  • could be due to bad cable
  • not enough power
  • data corruption
  • drive failure
  • bad usb ports
  • corrupted drivers
  • gremlins

I just connected my HD to my roomie’s macbook, and he was able to see it! So then I put it back in my computer and now I can see it again! 

Don’t understand why, but this solution worked! 

wow, nobody commented on my joke.  I guess people think gremlins do exist.

subgroover, it may have been a power issue.  are you using a laptop as well?  if so, was it, your laptop, plugged in the first time you connected the passport?  if not, then that may have been why the drive wasn’t fully spinning up.  not enough power from the battery. 

if none of that is the case, then maybe gremlins do exist.

Same issues as others on this thread, light comes on on my Passport SE hard drive but cannot locate via any tools on my macbook. One minute it was working, now it isnt.

I have downloaded the Firmware Updater but when I run the program it says “the updater download failed. Check your internet connection”. My internet connection works fine, so is there an issue with this firmware?

This is so frustrating!

if the drive isn’t being recognized, then most likely the firmware update will fail.  also does the drive show up in disk utilities?  if so, it’s possible that the drive got corrupted.