Passport Not locking correctly using Window 10 Pro

Anyone else having a problem under Windows 10 Pro with the Passport drive not locking correctly because Win 10 closes too quickly. My 16GB Dell 7010 shuts down in about 1 second flat! When I restart, after entering my pin and the desktop appearing, I get a “Recycle Bin corrupt on the passport drive, do you want to empty it” message. I say yes.
When I start Windows Explorer, I can see the virtual Unlocker drive and the Passport drive as well. Depending on the closedown time (1 sec, 2 secs etc.) I can reveal the folders and even the contents of folders. Sometimes I can even open the items in a folder (< 1 sec shutdown). Most times I do get blocked from contents however by Win 10 security.
WD told me to reload Windows Op system and the problem will go away. This I don’t believe because the workaround I have (forcing Win 10 to wipe the Page file before shutdown) allows the WD software the time to lock the drive correctly and on start up, only show the virtual unlock drive.
Seems there are many problems with the speed of shut down - Win 10 forcing shut everything that may be running regardless, so I’m not sure who the issue resides with - Microsoft or WD?
Any thoughts or other solutions.


I guess this is why WD says to always “Safely Remove Hardware and Eject Media”. I agree I wouldn’t expect to have to do it when shutting down the PC as Windows should take care of that. It is required for removing the drive or even a USB memory.

Why not do it before shutting down? It is a simple procedure.

For drives, except C:, open the drive property and select “eject”. Watch for a ‘Safe to remove’ notice. Or in the notification area click on the ‘up arrow’ (for Windows 10 anyway). Select the icon saying “Safely Remove Hardware and Eject Media” for each drive. Now you can shut down the PC.


Oops! I should have tried it before I wrote the above.

When I did try it I get a message: “Problems Ejecting USB Mass Storage Device. Close any programs using this device…” WD backup Help says to use the WD Backup ‘Pause and resume view menu’, which I’m supposed to find by clicking WD icon on the Windows taskbar. Clicking the icon displays WD Discovery with four options, none of which mentions
a ‘Pause and resume view menu’!

Come on Support: Where are you hiding this “view menu”?