Passport Not Loading

Okay so when I plug my passport in, the light comes on, and the wd ware thing pops up so I can back up my computer or install the drive. But other than that, I can’t access anything in my passport. I figured my issues was the usb cord had too many kinks, so I bought another one. It’s currently shipping now. But, my friend has the same passport. I used her cord to access my passport and again, it doesn’t work. What is going on?! I saw something about a test disk application which I’m going to try doing at home later. I’m at school right now and am not allowed to download anything. 

WDBAAA2500ABK-00 is the model

you must install the drive in order for windows to even recognize it. 

I’ve been using it for over a year and never once did that. It’s always worked so that can’t be the problem.

FIXED IT! and you were wrong, just so you know

Can you tell me how you fixed it please?  I am having the same problem.  bought a new cable tonight but isnt making any difference. 

mine was simply locked. when you plug it in, you should go to install and type in the password you put in when you installed it