Passport keeps turning off during backup

I’m trying to do a backup of my MACs HD (photo, docs) and the drive keeps turning off mid wa through the backup job. The only way to restart the drive is to disconnect the drive from the MAC and reconnect it. I already upgraded to the latest version of software but it is turning off.

Hi there, if the drive is turning off it is a power problem and has nothing to do with the software. Check the cable, try different USB ports on your computer, or use a power booster cable (USB cable shapped as a “Y” to double the power).

I tried a different USB port with the same result. I can copy files to the hard drive fine … But as soon as it is idle it shuts down.

I stand corrected … The copy to the passport failed towards the end of the operation.

when you changed the cable, what length did you use? anything more than 18 inches prevents enough power from getting to the drive.  also, disconnecting the drive like that could cause data corruption, so be aware.  it seems like the drive is trying to go into sleep mode.  make sure that you don’t have any power settings causing the drive to go to sleep early.  are you using a laptop on battery?  otherwise, you may want to contact wd and see what they say.

I seem to have the same problem with my mini from 2009 and a brand new MyPassport Essential USB 3.0 500 GB it seems to disconnect from the USB when idle and especially when the CPU is sleeping… (10.6.8 + SWare 138 and the Turbo+ drivers… last firmware iteration too).

Reconnecting the drive is not sufficient, as just rebooting the CPU… The mini needs to be turned off then booted again to recognize the drive!

At first I thought it was a cable problem…

Tried the drive on my macbook Pro from early 2007 (had Smartware/turbo drivers installed as far as I remember) : it works fine… but the MBP was running 10.7

Updated 10.6.8 on the mini to 10.7 : same issue I removed Smartware with its uninstaller: it removed the turbo driver too Tested again the drive on the mini with a similar cable but from an other MyPassport Essential 320GB USB3.0: it worked fine for 24 hours

Tried again my 500GB drive with the original cable: it works fine now for a couple hours…

So far my conclusion is that the Smartware/turbo driver combination with my Mini  is causing the “disconnect” problem Of course without the turbo drivers it seems like the drive peak speed is a bit lower (by approx 3 MB) but if it’s at the cost of not losing the drive every couple hours… that’s fine with me!

if you are using the original turbo driver, I can pretty much guarantee that it’s not compatible with 10.7, and may never be.  I would definitely get rid of the turbo driver on a 10.7 machine.  you will sacrifice a little on performance, but if it still works that’s great.

… well, at least it was not deactivated by 10.7 as incompatible software would be (my sil3132 kernel extensions were)

Anyway, the problem was the same wether it was on 10.6 and 10.7…

Now for approx 3 days in a row, without smartware and the turbo drivers the drive is “live” without any disconnection… before that I did not had to wait too long (a couple of hours) before it disconnected itself…