Passport Essential SE 1TB failure help please

I use windows 7 64-bit and have a My Passport Essential SE Model# WDBACX0010BBK-NESN.  I plug it in solid light comes on, PC says installing device driver like every time before I used it.  There are 4 line items:  1. USB Mass Storage Device (I get the green checkmark), 2. WD BAD PCB USB Device (get green checkmark), 3. WD CDROM USB Device (get gren checkmark), 4. WD SES USB Device (get red X and “No driver found”).

I check on My Computer and it is showing up as an empty CD Drive…

I have repeatedly unplugged the drive from my computer and downloaded the WD SES Driver 64-Bit from WD Website for my specific device and loaded it successfully.  Still when I plug in the drive I get the “no driver found”.

I also tried to plug it into an old pc and same thing.

I’ve been using it for a year as backup with password with no problem is there some other program or something I need to load?  I think it already had its own drivers on the passport…

Any ideas?


When you connect the drive, does it ask for the password?

How is the drive showing under disk management?

Check inside of the virtual CD to see if you can see the drivers for the drive and try installing that again.

1 Like


Thank you for responding.

  1. When I connect the drive it does not ask for the password.  (Every time before it did).

  2. Under disk management it is showing up as: “Disk 1 Unknown  Not Initialized”.

  3. I’m not sure what Virtual CD is.  I searched it but not showing up on computer.  Note* Before there was a green check by WD CDROM USB Device, now its red X, and does not show up under my computer at all. (I uninstalled the SES driver manually loaded from website and tried again, red x.  I then reloaded the SES driver from website (zip file) and same red x.

  4. I used the “Hardware and Devices Troubleshooter” with online connection in Windows and it found 3 problems.

    A. WD CDROM USB Device has a driver problem (not fixed)

    B. WD SES USB Device doesn’t have a driver (not fixed)

    C. Hardware changes might not have been detected (detected)

The worst part is I got this drive out to check it because my internal hard drive with all my data died.  I feel sick.

I ordered a new cable and now the WD CDROM USB Device has a green check by it again and empty cd drive showing up under my computer again.  I think the problem is with the driver and the fact that the prompt for the password is not showing up so I can unlock the drive.  Is there a WD Application or software for this or some other program I should know about?

Hello Donuts,

Check the link below for assistance installing the drivers

If you install the drivers and stills the same, I’ll recommend you to run the firmware updater from the following link.

IMPORTANT:  The following precautions should be taken before installing the firmware update.

  • Before updating the firmware on your drive, make sure you have a copy of all the data on your drive stored on a separate device.
  • An available USB port on your computer is required. Your drive MUST be connected to your computer through the USB port to update the firmware.
  • If you are using a laptop, please make sure the battery is sufficiently charged
  • During the firmware update, DO NOT disconnect or disrupt the power to the drive.
  • All AntiVirus software MUST be disabled.
  • All Anti-Spyware software MUST be disabled.
  • ANY and ALL programs that would require drive access during the update MUST be disabled .
  • An internet connection is required to install the firmware update.

I have exactly the same problem and symptoms as Donuts and have tried all the same troubleshooting steps with the addition of deleting upper limit and lower limit registry entries which worked for some people.

I have already tried installing the 64 bit SES drivers form this link:

I have already tried to run the firmware updater from this link:

Installing the 64 bit SES drivers does not help. The same problem persists as Donuts already described it.

Attempting to update the Firmware does not work because the drive is not mounting so the Firmware updater does not recognize anything to update.