Passport Essential SE 1 TB Failed after 4 Months

I have a Passport Essential SE TB external hard drive which I purchased brand new four months ago.  It was used appropriately and never mistreated.  I never put more than 400 GB on it at any given time.  I run Windows XP Professional on my Dell laptop

I can access and view my files but I cannot remove them from the hard drive nor can I add any new files to the drive.  I receive a message which says, “Windows - Delayed Write Failed”.  I have tried the hard drive on several Windows based PCs with various Windows Operating Systems and the same message appears on all of them,.  I ran Data Lifeguard Diagnostics and it “Failed” the test within seconds of starting the program.

Data recovery companies recommended on WD’s website are all quoting around $500 to recover my data.  I feel WD should pay for and do the recovering on my behalf since their product failed miserably within a few months of purchase.

Any suggestions?

You just learned the importance of backups. That’s 2 copies in different drives or mediums. Moving files from PC to an external drive is not a backup if it’s the only copy. Any drive can fail at any time. It doesn’t matter who makes the drive internal or external. If you read the warranty it excludes data recovery.


have you tried changing the data cable?  sometimes a delayed write failed can be a bad cable as well.  make sure that it’s no more than 18 inches, or it won’t power up the passport completely.