Passport Essential only works if I plug it in after booting up Lion

2 days ago I noticed my passport backups quit working. The drive had been working flawlessly with Lion since July up

until now.

I’ve tried both USB ports on my MBP mid 2010. Same problem. I’ve updated the firmware to the usb

drive. Didn’t help. I tried to install the turbo drivers but the installer just hangs.

The only way it will work now is if I turn off the computer. Unplug the drive. Start the computer, then

plug it in.

Interestingly enough, I can see the drive in Finder and browser the folders and files if I boot up with it plugged in

so I know it’s being read. It’s just not available for backups with either get backup 2 nor with Time Machine.

Also… the device shows up on my desktop if I plug it in after the OS boots but not if I boot up with it already

plugged in.

Any help???

Thanks so much. Very frustrated.

I hope this helps others if they have the same problem.

Just 2 minutes ago I figured out the problem.

I’ve literally spent nearly 7 hours trying to figure this out.

I was just looking at System Preferences when I noticed

the “Startup Disk” icon. I clicked it and what do you suppose

I saw? The gosh darn external drive was selected as the default

drive. That is why it wasn’t showing up after bootup. It was booting

from there. I didn’t notice because the performance wasn’t really

that bad. Arrrrgh!

that’s really good to know.  you have any idea how it ended up like that?  that way others can prevent the issue before it happens.