Passport Essential not working. "I/O device error"


#1

I am having terrible problems with my new Passport. I tried using it without the software from the start. It started receiving photos then came up with a device error:- 0x8007045D. Anyone know what that is? some pics transferred but when I tried to organise them into a new file - it failed and I lost about 50 photos and 6 video clips!!

By rebooting, it took a few more but failed again, with the same error number. 

I tried installing the software - not working. I tried updating the software. Not working. Having lost photos and wasted most of the dayI want to stamp on it!

Of course, no technical help available for days…


#2

NO ONE (including virus software geeks) i paying attention to this new development. All three of my WD externals have the “I/O device error” of doom message. They are spinning out of control as soon as you plug them it. All data is being held hostage on them (1tb in all). It’s not just WD… It’s Seagate and all the rest. When you Google the problem people are begging for help to recover their data all over the place. Some kind of virus that everyone is turning their head on. Attacking portable hard-drives right now.

Good luck, I know I need it (no reps responding from McAfee or SeaGate or Western Digital) It’s off the chain.