Passport 2TB's "Backup Now" does not work

I just bought a new 2TB My Passport. AFter installing all the software in my Windows 10 PC, I tried to backup some folders from my PC to Passport, but after I set all the parameters and press the "Backup Now: button, nothing happens.

1 Like

Make sure that the drive is working manually.

Take a look on the link below:

Did you get this fixed?? I’m having the same issue with my drive after the latest windows 10 update…

I am facing the same issue. I got a My Passport 1TB, installed the WD Discovery and WD Backup. Although I have scheduled a backup, the button Backup Now does not work. I’ve tried to get in touch to the local WD support, however, the problem was not solved so far.

SAME issue…BACK UP NOW button does not work. It is visible, but does nothing when pressed. I have done everything possible to fix this problem. I have cleaned my computer, running Windows 10, etc etc. This will be my VERY LAST WD product because we’ve bought three so far. A big company like WD and there’s no answer for this problem? You have to be kidding me. I’ve looked everywhere and do not see one. Wow. :rage:

UPDATE…EVEN SCHEDULED BACKUP does NOT work…what the hey???