Parental Control Website Down

I am unable to register or re-register my N900 router, and cannot access the “” website directly or via the router Admin page, to create or modify Parental Controls. I completed a hard reset and restored a previously working configuration …

Is anyone else experiencing this problem? Is WD providing Parental Controls for their legacy routers anymore?

Hi there,

Are you getting an error ? Also did the parental control settings work before doing the reset?

Previously worked, and I’ve been using Firmware 1.07.16 for a while. Link to “Re-Register Router” is gone, and when I attempt to register router in immediately responds “Request fail”.

Note that the “” website still does not appear to be working. I don’t use a proxy, and I get the same website response using 3rd party website tests.

I’m having the same issues. Seems like they stopped supporting Parental Controls! Not very customer friendly.

As a parent, this is a HUGE deal to me. If it is a service that is no longer provided, I would have expected an email notification before I noticed my children browsing the web unchecked. Every registered router has an email address. I assume that WD TV Hubs no longer have parental controls either . . . .

I spoke with 2 customer service agents regarding this. They both were unaware of such a website for parental controls, I first noticed that the inappropriate site screener was not working a few weeks ago, but didn’t act on it till today. I also had a time setting for my son’s internet use. Both settings are now gone. Customer service has no solution.

Well that means that we now have no way at all to control our devices with time schedule anymore. My teens are very happy about that.
Please tell me you will do something about it.
Dont let us buy a new Router.

I’ve just bought the N900 Central Router and trying to set up Parental Control but the site “” does not work. Now I see this thread - where is WD in this matter??
This feature is needed!
WD are you there??

I’ve been dealing with customer service regarding this issue for the past week. Western Digital is getting out of the router business. And therefore are not supporting the parental controls Security website anymore. I believe this happened about a month ago. I’m returning mine to Costco

It’s also very deceiving. The ones that are selling online still indicate parental control abilities.

You are lucky to be able to return it. I have mine since 2012, and didn’t need the parental control until few months ago. It was doing fine and then without any notifications, stopped to works. That what we get when we try to give a chance to a new player in a new domains. Next time I will buy only from companies who are able to support their products more than 3 years. WD do you think I will be on your side next time you launch a new product you haven’t sell before?

I noticed that I could not register my router after doing a factory reset. I thought that I had forgot my password. I tried all three of the emails I use, every password I have ever used, I grew very frustrated. I relied on the link in the router software to navigate to the website to adjust settings so I actually didn’t know what the website was until downloading the manual. Once reading the manual and going directly to the website I see that it’s not working. I’ve been struggling with this for two months for no reason, all because WD decided to not support it any longer. The least they could do is release a new firmware that removes the parental controls option from the interface which would give me a clue that it’s not supported any longer. I’d still be mad but at least I’d know.
I’ll never buy a WD product again, not a new product, not even a hard drive! If this is what I can expect from them on obsolescence policy, I don’t want to rely on them for important parts like memory or hard drives.