Parental Control password stopped working

I set up parental controls on my router, and all was working well except Netflix would not come though on our PS3 systems. The PS3’s didn’t even show up at first in the parental control area of the router, and when they finally did, they wouldn’t register. So I tried using the MAC filter to force one to show up, and then that prevented me from getting online with my other devices, so I couldn’t even get back into the router to change settings.

So I did a hard reset of the router and went through all my setups again, but it would not let me log back into the parental controls area. It also would not let me set up a new parental control account or “unregister” my router from the parental control system so that I could start over. It won’t even take the confirmation password that I was sent the first time around when I set up the parental control. I’m basically not able to do anything regarding parental controls. 

I’m confused and frustated. Any help would be appreciated. If nothing else, how to you unregister a router from the parental control system?


Have you tried setting the unit back to factory restore?

Check the link below

How to reset a My Net Router to Factory Default Settings

This happened to me too - I did reset my router back to factory defaults and still no luck.  Now I cannot re-register my router, every time I enter a email address and password it says it is trying then ends in “Request fail”.  I am on the internet so not sure what the deal is.

Same thing for me. Not sure if they’re working on the site or not. Let’s see if things improve Monday.

I did try the factory restore, both physically on the router and in the software. Neither worked. The same thing that the other folks in the post describe is what is happening to me. I can’t find a way to unregister the router for the parental controls so that I can reregister it.

Looks like they have it back up and running. Password and filtering now working.

Apparently there are still some issues as the router sometimes freezes in sending further data to devices necessitating a restart of the router.

Additional issue found: when a site is blocked, error message “invalid authentication” appears when password is entered to allow access. Any news when the parental controls service/password issues will be resolved?

My apologies on so many updates. Just wanted to share that I’ve opened an email support request for this last password issue “invalid authentication” when attempting to allow a blocked site. Will update the thread once I’ve received any resolution. Thanks.