Panasonic TX 50CX700 & MyCloud Shared Folder

My Panasonic smart TV under ‘Shared Folder’ in ‘File Sharing Settings’ is requesting that I enter a location, but I have tried several options ie shared, public, Twonky, MyCloud etc but nothing seems to work, just comes up with not found, what am I doing wrong? Maybe I have entered something wrong elsewhere?
I am new to MyCloud so keep it simple please!
When I forst connected the TV to the server everything worked, have I altered something on the server?

If you haven’t done so already download and read the My Cloud User Manual ( which explains how to use the various options/features of the My Cloud. The user manual explains which media formats the My Cloud media server supports and how to turn on media serving for a Share (where you store the media files on the My Cloud) so DLNA clients can access the content.

If you don’t know how to access the My Cloud Dashboard to check/configure media serving on Shares see the following knowledgebase article.

And lastly see the unofficial media server FAQ which may have additional information that may help with your issue.

Well I finally have got this working again. I also posted on Digital Spy, and got several replies including doing a system reset, but I tried an easy one first which was to use a static IP address and this solved the problem. I am now thinking of buying a Kodi Box ito stream my videos, s this easy to set up with the MyCloud drive?

Yes. You just point it at the SMB file server running on the MyCloud, and tell Kodi which folders to scan. Using the file server is better than using the DLNA media server because you can use Kodi’s ‘media scrapers’ and get all the episode titles and artwork.

Well after a couple of days I can now give an update. The only problem I have left is that my PCs and the TV keep losing the File structure on the NAS, sometimes its there and sometimes it isn’t. The Network sees the Nas in Media Devices and in Storage but I am not able to access the file structure - Media Device goes directly to Twonky, Storage goes directly to settings page. Can anyone help?

I have now installed an Android TV box with Kodi and this can’t see the Videos either, I have put some test videos on the Nas drive in MP4 format and ISO, so Kodi should be able to see them?

Map the Shares as network drives. Map a private share first, and give your MyCloud user credentials. Tell it to reconnect at login.

Fix the IP address of your MyCloud; I’d recommend doing this at the router, forcing an infinite DHCP lease time/timeout.

1 Like

How is Kodi accessing the media? As an SMB file server, or using the DLNA media server. As above, I strongly recommend the former.

Videos/Files/Add videos…/Browse/Windows network (SMB)

I am having problems with this, my NAS does not appear in the left hand column of file explorer, it only appears when double clicking on Network in the left column of file explorer and then it appears in 2 places in the large pane, these items cannot be expanded, expanding Network in the left column just shows the PC in use. So Mapping Network Drive says it can’t find anything! Here lies the route of the problem I think.

I have managed to get Kodi working for thanks for help on that.

Great news after many hours I have finally got this to work (hopefully), I mapped the drive and it now appears in the left pane of File Explorer, many tahnks for help - onto next problem now!