Panasonic TV DLNA Sort Order

Hi All, 

I had to do this again after the update and I’d forgotten how to do it, it took me a while to find the tutorial I used so thought I’d post this for anyone who doesn’t know how to do it or that needs to do it again after the update!

On Panasonic Tvs when using their built in media player files are sorted by creation date rather than alphabetically and this can get seriously annoying!

Before I found this solution I had tried everything including using freeware which changed all my creation dates to the same date and this still didnt fix it as the mycloud had someway of knowing a hardcoced creaton date.

Anyway to fix the issue and sort everything alphabetically you will need to:

  1. Download the free program winscp

  2. Log into your mycloud UI and turn on SSH, write down the login and password (yours may be the same as mine but may not)

  3. Open winscp and enter the ip of your mycloud and the login details it provied for ssh.

  4. Navigate to /usr/local/twonkymedia-7/resources/devicedb/Panasonic

  5. Find the .xml file for viera tv (It may be a good idea to make a copy of this to be on the safe side, just drag it to your desktop)

  6. Then open this .xml file and you will see a page of what looks like code, near the bottom of this is a section with some Quirk tags and in with the ones already there you need to add IGNORESORT, make sure you put this before the closing tag 

  7. Hit the save button.

8*. This may now be already working for you, if not you may simply need to set the server, go back to your browser of choice and put in your mycloud ip followed by :9000 and this will take you to the twonky page, click on advanced and then go down to the bottom and click restart server.

This should now fix it for you :slight_smile:

Good guide

I make some more general suggestions in my FAQ

Q. How can I get Twonky to provide full size artwork to media-playing clients?

Q. How can I change the media ‘views’ I see in my DLNA client?

The tutorial you couldn’t remember may have been this:

Hi, thanks very much for putting up this workaround. I tried this, however I am running into issues where the filesystem is readonly and won’t allow me to modify the Panasonic_VIERA.xlm file. Can you please advise how I can get around this issue so that I can enter the IGNORESORT Quirk tag?

As posted to your other post in another thread where you asked the exact same question. Have you tried changing the file permissions via SSH? Once you change the file to read/write and edit the file, change it back to its default setting.

Yes unfortunately this workaround only works on older hardware. I have contacted both wd and twonky. Twonky have added a new file to their database but this will only benefit us if/when wd decides to upgrade the twonky version in their update. Wd did not seem to have an answer as to why this workaround doesn’t work on new hardware or an answer to if/when the twonky version will be updated :frowning:
The only other option twonky suggested would be to do a custom install of the new twonky but I wouldnt know how to do this I’m afraid :frowning:

I added a suggestion to my Twonky FAQ, about getting more recent device profiles from Twonky install kits. See “Q. How can I change the media ‘views’ I see in my DLNA client?”

Hi,The file itself, Panasonic_VIERA.xml has permissions of 775 and owned by root and I should be able to change it, however it the filesystem mounted as read-only. I suspect that I need to try and unmount and remount the filesystem as read/write, then umount and reboot. I am surprised that this incredibly simple fix of adding IGNORE SORT to the VIERA xml isn’t a standard part of the configuration file.
Come on WD!!! Please give me the ability to list my videos by alphabetical order!!! I don’t want to be messing around with the Linux OS like this.

@Ajit_Rasiah, this is a user forum (user to user assistance), if you want to let WD know, open a case or submit your request via official WD channels.

Now, the following is not a solution, but lots of headaches can be solved with a media player such as Amazon Fire TV stick which is only $40. SmartTVs are not that Smart, yet, IMHO.

What are you using to try and change the file? I was able to change some info in the “Panasonic_VIERA.xml” file located in the “/usr/local/twonkymedia-7/resources” and save it using WinSCP ( on a Windows 7 PC. I changed the DisplayName value to the following: <DisplayName>Panasonic VIERA AAA</DisplayName>

After rebooting the My Cloud the change is reflected on the Twonky settings page. Below indicates the changes:

The problem is with new hardware the folder has been relocated to \modules\twonky\ and the modules folder is read only. The only solution I have found thus far is to put all my videos through mkvtoolnix and the date will change to present date although I admit this is not a proper fix

Also I have already let wd know about the problem and the only reply I got, although this was a few months ago, was that ssh is not officially supported so they could not comment on what could or could not work for some devices and not for others. I will state again my fix will still work fine for people with the original mycloud but it does not work for the mycloud ex2100 and I assume it does not work for other newer hardware due to the relocation of the twonky files to a read only folder

I had downloaded and used WinsSCP, and ran into the file system read-only issue.
I then tried an alternative way, which was to login through my Raspberry PI using putty, both as ‘sshd’ and as ‘root’ and still ran into the same issue.
I am using a WD DL4000 My Cloud and I wonder if the setup is a bit different.
Here are the outputs from some basic commands I ran:

/usr/local/modules/twonky/resources/devicedb/Panasonic$ ls -l
-rwxrwxr-x 1 root root 314 Sep 7 2015 Panasonic_DIGA_Blueray_player.xml
-rwxrwxr-x 1 root root 568 Sep 7 2015 Panasonic_DIGA_Blueray_recorder.xml
-rwxrwxr-x 1 root root 1486 Sep 7 2015 Panasonic_VIERA.xml

/usr/local/modules/twonky/resources/devicedb/Panasonic$ df -k
Filesystem 1K-blocks Used Available Use% Mounted on
mdev 1019492 4 1019488 0% /dev
/dev/loop0 106880 106880 0 100% /usr/local/modules
tmpfs 4096 1604 2492 39% /usr/local/config
tmpfs 1024 0 1024 0% /mnt
tmpfs 40960 8600 32360 21% /var/log
tmpfs 102400 2692 99708 3% /tmp
/dev/sdb4 951204 1516 933304 0% /mnt/HD_b4
/dev/sdc4 951204 64 934756 0% /mnt/HD_c4
/dev/sda4 951204 2148 932672 0% /mnt/HD_a4
/dev/mapper/md1 5805904812 232270896 5515096312 4% /mnt/HD/HD_a2
cgroup 1019492 0 1019492 0% /sys/fs/cgroup

/usr/local/modules/twonky/resources/devicedb/Panasonic$ cat /etc/fstab
proc /proc proc defaults 0 0
/dev/ram0 / ext2 defaults 1 1
sysfs /sys sysfs defaults 0 0
mdev /dev tmpfs defaults 0 0

/usr/local/modules/twonky/resources/devicedb/Panasonic$ mount -l
%root% on / type unknown (rw)
proc on /proc type proc (rw)
/dev/ram0 on / type ext2 (rw)
sysfs on /sys type sysfs (defaults)
mdev on /dev type tmpfs (defaults)
proc on /proc type proc (0)
devpts on /dev/pts type devpts (noexec,nosuid,gid=5,mode=0620)
squash on /usr/local/tmp type ramfs (size=107m)
/dev/loop0 on /usr/local/modules type squashfs (rw,offset=2048)
tmpfs on /usr/local/config type tmpfs (size=4m,nr_inodes=0)
tmpfs on /mnt type tmpfs (size=1m,nr_inodes=0)
tmpfs on /var/log type tmpfs (size=40m,nr_inodes=0)
tmpfs on /tmp type tmpfs (size=100m,nr_inodes=20000)
/dev/sdb4 on /mnt/HD_b4 type ext4 (rw)
/dev/sdc4 on /mnt/HD_c4 type ext4 (rw)
/dev/sda4 on /mnt/HD_a4 type ext4 (rw)
/dev/mapper/md1 on /mnt/HD/HD_a2 type ext4 (rw,noatime,nodiratime,barrier=0,usrquota,grpquota)
cgroup on /sys/fs/cgroup type tmpfs (rw,uid=0,gid=0,mode=0755)

I have read from other (unrelated) posts that people are having difficulties with /dev/loop0 being read-only. So not sure now how to proceed.


Yes the firmware and file structure for the DL series might/will be different than the setup on the single bay My Cloud devices which is the general subject of this subforum. Same goes for the person above who mentioned the EX series. WD has decided (for what ever reason) to have different firmware between their various devices which leads to issues like this where a fix for one My Cloud version (in my case a v4.x single bay My Cloud) may not work on another My Cloud model. This is something we users have commented on before.

If you haven’t done so already you may want to search through the DL My Cloud subforums to see if there is any solutions listed there to your issue.

I found the perfect solution to this issue.
I turned off the standard media server that comes with the DL4000, loaded the PLEX app into the DL4000, and voila! PLEX does exactly what I need which is to sort out my videos, music and photos in alphabetical order. Thought I would share this, as I am sure many others may benefit from trying out PLEX.

This subforum is primarily geared towards discussing the single bay My Cloud units. It should be noted that the single bay My Cloud units do not officially support Plex. There is no official Plex third party installable module for the single bay My Cloud units like there is with the multi bay more expensive My Cloud units.

You can put PLEX on a DL series unit, and not have to turn off “the standard media server” i.e. Twonky . I can have both running; PLEX is self-contained and is not interacting with Twonky… Also, I usually access media on my DL2100 via SMB, and not UPnP from my computers, media player and my mobile devises and the media files are all in alpha order. I have both iOS and Android tablets, and most iOS tablets access via SMB, and I have a few that can access via UPnP, or even both (e.g. Infuse app)…

Android (Kindle) tablets have mostly UPnP apps on them e.g. Bubble/UPnP that can be adjusted to show media in alpha order if I want to.

Bottom line: PLEX is not necessary if one knows how to use the apps and equipment.

I managed a workaround which works until the device is restarted, i.e. I can update the XML files and Twonky uses the new views/files until a restart of the device.
Twonky currently sort for me Video/Genre, Panasonic view is also corrected.

The workroud takes about 2 Minutes.

I have to wait a few days to observe how often I have to repeat it.
If required, I could add it here.