[PACKAGE] Tautulli / PlexPy, adds monitoring, analytics and notifications for your Plex server


#38

Does the new package install python in entware?

/opt/bin/opkg install python-light

You also need the entware package now.


#39

root@MyCloudPR4100 Tautulli-master # /opt/bin/opkg install python-light
Package python-light (2.7.15-1) installed in root is up to date.
root@MyCloudPR4100 Tautulli-master # python ./PlexPy.py --port 8282
Traceback (most recent call last):
File “./PlexPy.py”, line 24, in
from Tautulli import main
File “/mnt/HD/HD_a2/Nas_Prog/tautulli/Tautulli-master/Tautulli.py”, line 35, in
import plexpy
File “/mnt/HD/HD_a2/Nas_Prog/tautulli/Tautulli-master/plexpy/init.py”, line 33, in
from apscheduler.schedulers.background import BackgroundScheduler
File “/mnt/HD/HD_a2/Nas_Prog/tautulli/Tautulli-master/lib/apscheduler/init.py”, line 1, in
from pkg_resources import get_distribution, DistributionNotFound
ImportError: No module named pkg_resources
root@MyCloudPR4100 Tautulli-master #


#40

Shoot, didnt mean to respond just the error. I still see this error. I installed entware then the package from the admin UI manual app install


#41

I have this

root@MyCloudPR4100 tautulli # /opt/bin/opkg install python-light
Package python-light (2.7.15-1) installed in root is up to date.

And these results from looking at other posts

root@MyCloudPR4100 Tautulli-master # python --version
Python 2.7.5
root@MyCloudPR4100 Tautulli-master # openssl --version
openssl:Error: '--version' is an invalid command.

Not sure if that is helpful?

Thanks!


#42

Uninstall Tautulli.
Install Entware via the web UI. It plugs into your PATH so you may need to reconnect over SSH to reload the new /etc/profile.
Then install the new Tautulli package.
Press configure in the web UI and it should be fine.

If it isn’t, open a new SSH session and ensure python 2.15.1 is installed

/opt/bin/python --version

Ensure you’re using the new python, not the system version.

which python

Then check that the python package manager is installed

echo $PATH
which pip
pip --version        or /opt/bin/pip --version

Finally try adding python setuptools, as pkg_resources module is part of that package.

opkg update
opkg install python-setuptools

If it still doesn’t start after all this, please provide the error of

/opt/bin/python ./PlexPy --port 8282

I’ll retest with a new entware environment later this week and update the install script if necessary.


#43

Thanks, I tried the steps you mentioned. It seems pip is missing. I also ran through the python-setuptools part

root@MyCloudPR4100 Tautulli-master # /opt/bin/python --version
Python 2.7.15
root@MyCloudPR4100 Tautulli-master # which python
/opt/bin/python
root@MyCloudPR4100 Tautulli-master # echo $PATH
/opt/bin:/opt/sbin:/sbin:/usr/sbin:/bin:/usr/bin:/usr/local/sbin:/usr/local/bin/
root@MyCloudPR4100 Tautulli-master # which pip
root@MyCloudPR4100 Tautulli-master # pip --version
-sh: pip: not found
root@MyCloudPR4100 Tautulli-master #

last error

root@MyCloudPR4100 Tautulli-master # /opt/bin/python ./PlexPy --port 8282
/opt/bin/python: can't open file './PlexPy': [Errno 2] No such file or directory
root@MyCloudPR4100 Tautulli-master #

I did get everything working from my Windows 10 PC… but will continue to test running off the WD which would be preferable

Thanks again!


#44

If you don’t have pip, you didn’t install the Tautulli package after installing Entware.
Uninstall Tautulli, install Entware, install Tautulli.
Check if it works.

If not, open a new ssh session.
Install python-setuptools

opkg update
opkg install python-setuptools
opkg list_installed

If you don’t have opkg, you didn’t install Entware or didn’t open a new ssh session.
Try to run the PlexPy.py script directly. But use cd to change to the correct directory first…

cdnp          # alias to go to Nas_Prog
cd tautulli/Tautulli-master
/opt/bin/python PlexPy.py --port 8282

#45

Thank you very much, I redownloaded everything and tried again and it is now working! Thank you again!


#46

@Tfl I have followed all of the listed instructions, and I can not get it to work on any aspect. I keep getting the port is not available. I also know that I do not have the newest version of Python either. My Unix skills are not as good as they used to be…


#47

What do you mean with ‘the port is not available’? I need the output from the SSH shell to know what’s going wrong. If you’re talking about

/opt/bin/python PlexPy.py --port 8282

It means that Tautulli is already running on http://:8282.
You could kill it and restart it.

ps w | grep PlexPy

Look up the PID (first number) and kill it


#48

Nevermind, I see there’s again some changes on Entware’s side that broke the package.
It seems like pip fails to install.
This fixed it for me

opkg install python-pip

New package incoming in a few minutes.

EDIT: new package available!

  • Fixed installer again
  • Keep config and db on future upgrades
  • Installs git now to make it easier to switch to beta / apply hotfixes
  • Added entware init.d bootscript to ensure that entware’s clean will stop tautulli

#49

You are more than welcome to contact me directly if you wish? I have the ability to remote into my computer so that I may watch / learn . I also do not have the ability to do opkg. I am using a Mac and I have Cyberduck as my SSH


#50

There was a bug on my website causing an older Entware version v1.03 to get selected instead of v1.04.
This version uses entware-ng, which is no longer maintained and points to outdated packages.

Anyway, the Tautulli package now works for both.


#51

It seems to be working now. So hopefully all goes well. :slight_smile:

Thanks,

D. Matthew Friend

matt@emttech.net

570-240-6396


#52

Hello,
I have some problems with Tautulli on my NAS PR4100.
network error http://192.168.1.13:8282 ???
I just saw that he had just updated Tautulli version 2.1.20.
Moreover with your version impossible to install the 2.1.18b corrupted package forced to installed an old version.


#53

The version of the WD package is actually unrelated to the official release version.
The WD package just fetches the latest stable Tautulli version.

The Entware package is now mandatory.
So to wrap up… what version of Tautulli / Entware do you have now (according to the WD web UI)?


#54

Ok I uninstall Tautulli
Then restart
Installed Entware then Tautulli
and it works properly


#55

I always get the message that my connection was declined by my NAS IP once I try to open Tautulli through http://192.168.1.58/tautulli/index.html or 192.168.1.58:8282

What I tried:
Restart
Reinstall Entware-ng (1.04)
Install Tautulli (2.1.18b)

Maybe useful infos:
MyCloud PR2100
Python 2.7
OpenSSL 1.0.1m 19 Mar 2015

Edit: Tried to follow to above steps and getting this error while trying to run opkg update
opkg: /opt/lib/libc.so.6: version `GLIBC_2.27’ not found (required by opkg)


#56

Thanks for the clear info.
I think the upgrade from the old entware-ng to the current entware (without ng) may fail sometimes.
The uninstall script doesn’t delete the entware directory (I thought it was a good idea at the time).

Please try this:

  • uninstall Entware and any app that depends on it (e.g. Tautulli)
  • completely remove Entware with this command: rm -rf /shares/Volume_1/entware
  • install Entware and Tautulli

Note: you may want to backup your Tautulli settings and database, see the opening post.


#57

Thanks a lot for the instructions! After removing and reinstalling entware (+ tautuilli) it finally worked.