OwnCloud

#1

Has anyone Tried to install OwnCloud to the My Cloud?

The original cloud software is pretty much useless in many ways, so I would like to use this handy software but this topic is out of motivated experts to write guides for newbies like me. :\

My Book Live has OwnCloudguide, so I guess it is not impossible to install it to mycloud somehow.

Is it possible to install easily with this guide on the official page?

http://software.opensuse.org/download/package?project=isv:ownCloud:community&package=owncloud

Debian v7

Has anyone tried to overwrite MyCloud NAS with Ubuntu Server?
[GUIDE] Owncloud
Owncloud safe setup
#2

…would love to have it, but I’m really afraid to brick my device - and since there is no unbrickification manual for this device yet, I better won’t try…

In the manual you linked to, it said something like “simply using apt-get without further ado could easily make your device unusable” - so better be careful with that… The good thing is - the Debian version used already seems to have php5…

Anyone got some experience with owncloud in mycloud :stuck_out_tongue: ?

1 Like
[GUIDE] Installing OwnCloud Server on My Book Live
#3

Hi,

Im also intrested in installing owncloud. So if anyone has any idea how to do it without bricking the device I would really appreciate!!

Thanx:

B.

#4

I’ve managed to install it, but it has an error message:

  • PHP module GD is not installed.
    Please ask your server administrator to install the module.


SSH says:

The following packages have unmet dependencies:
 php5-gd : Depends: php5-common (= 5.4.4-14+deb7u7) but 5.4.11-1 is to be installed

#5

I tried to install opencart and had those same issues, in every way (although, I am a novice) I couldn’t manage to do it, and in the end I bricked my system, restored it now. So good luck and keep me updated haha, I’m quite interested in using owncloud too.

#6

I guess I made it work, little slow but it is working! :slight_smile:

So now it is testing time! :slight_smile:

2 Likes
#7

Cool!!!

Waiting for the guide!

Köszi!! :slight_smile:

#8

Awesome work. I second this motion! 

:smiley:

#9

Good work.  I hope if there is a guide to install it.

#10

cool!

wish you could write down some lines to explain how you did it… thanks!

#11

It works!

But little bit slow…

Install is easy.

I will write guide later.

1 Like
#12

Is the WD Interface working?I could make mine work but I lost the WD interface.

#13

any update on the guide?

Also waiting for my my cloud device I will try to get pyd.io running on it, a bit more light weight then owncloud and same functionality. But a guide for owncloud would be great to have :) 

Also so someone unbricked their device? How was that achieved? Just a simple restore?

#14

FearL0rd wrote:

Is the WD Interface working?I could make mine work but I lost the WD interface.

Yes I got mine working without losing the WD Dashboard interface (see my pointer #3). But it’s a bit slow though, can’t expect much from an arm7v1 600Mhz dual core. I would prefer if we could integrate the existing WD users without having a separate pool but this would need a lot of effort to achieve.

It’s actually a pretty straight forward installation following the existing My Book Live guide from the TS. The only tricky part is the “php5-gd” installation where you can risk losing the WD interface.

Since WSGVET hasn’t got the guide started yet, I’ll give a few pointers that differs from My Book Live from the original Guide:

UPDATED : Guide is only for v3 firmwares as apt-get will not work on newer v4 firmwares due to the 64K page size memory! For v4 firmwares, you’ll need tough luck to manually build and install a 64K patched php5-gd deb. Read more about the 64K stuffs here  http://community.wd.com/t5/WD-My-Cloud/Building-packages-for-the-new-firmware-someone-tried-it/td-p/768007

  1. Of course with root ssh access keeping in mind warranty=null, skip everything in the guide from start to the part where the author has updated " EDIT: <NEW_STEP>". Just after “rm -f /var/lib/dpkg/info/wd-nas.*” which you don’t have to perform for this case.

  2. For “/etc/apt/sources.list”, just comment out the 1st line “wheezy main” and un-comment the 2nd line “sid main” before you do the “apt-get update” command. You may revert back once OwnCloud has been installed.

  3. This is the most crucial part else you’ll lose the WD Dashboard. Do not install anything else and only run “apt-get install php5-gd”. When you run this, there’ll be prompts to install and upgrade, choose yes (make sure nothing is to be removed). There’ll be another few prompts to overwrite some php *.ini files (you won’t miss this), choose to keep them.

  4. For the apache2 conf file, assuming you are installing in “/var/www/htdocs/owncloud/”, create a new file “/etc/apache2/conf.d/owncloud.conf” and paste the “<Directory… >” lines from the guide in it. You only need this one file for both http and https.

  5. Finally when you try to install OwnCloud from your browser  http://wdmycloud/setup-owncloud.php and encountered some SSL errors, edit the /var/www/htdocs/setup-owncloud.php line 139, change to " FALSE" for “curl_setopt($ch, CURLOPT_SSL_VERIFYPEER, TRUE );”. If you receive permission write errors, as pointed out in the original guide, temporarily add write access to the www-data group “chmod g+w /var/www/htdocs”.

Edit #1 : I just noticed the WD email notification was broken after installing php5-gd. Fixed with below, run in shell:

ln -s /var/www/rest-api/lib/pear/includes /usr/share/pear

  Edit #2 : Speed up Apache2. This will help to improve OwnCloud. Change the values in file below to 256. You can play around with the rest of the settings but only changes below will not greatly impact memory usage when the server is idle.

/etc/apache2/mods-enabled/mpm_prefork.conf:
MaxRequestWorkers 10 -> 256
MaxConnectionsPerChild 10 -> 256

For edits above to take effect, httpd restart is required:

service apache2 restart
1 Like
#15

^updated…

#16

Your instructions, which I followed to the letter bricked my WD My Cloud. It is a soft brick as I can access through SSH, but all is wiped out, how can I reinstall the entire OS???

#17

Not sure what you meant by wipe out? May be some of the dependencies got replaced. See here to restore your soft brick… http://community.wd.com/t5/WD-My-Cloud/help-me-unbrick-my-soft-bricked-my-cloud/m-p/781061#M19928

#18

Thank you for the guide!

I somehow managed to install owncloud, the web installer said it was successful, the only problem I encountered was an error when installing the php5-gd package and when I tried to restart the apache server it wouldn’t start again. This is why I now can access neither the Web-UI nor the Owncloud via html.

I also had a different sources.list on my device - maybe this was the problem - Mine was when i tried to install php5-gd:

#deb http://ftp.us.debian.org/debian/ wheezy main
deb http://ftp.us.debian.org/debian/ jessie main
deb http://ftp.us.debian.org/debian/ sid main
#deb http://ftp.us.debian.org/debian/ experimental main
#deb-src http://ftp.us.debian.org/debian/ wheezy main
#deb-src http://ftp.us.debian.org/debian/ jessie main

When I try to start apache2 this happens:

“Starting web server: apache2apache2: Syntax error on line 141 of /etc/apache2/apache2.conf: Syntax error on line 1 of /etc/apache2/mods-enabled/php5.load: Cannot load /usr/lib/apache2/modules/libphp5.so into server: libonig.so.2: ELF load command alignment not page-aligned
Action ‘-k graceful’ failed.
The Apache error log may have more information.”

Apt-get gives an error of unmet dependencies:

“You might want to run ‘apt-get -f install’ to correct these:
The following packages have unmet dependencies:
 php5-apcu : Depends: phpapi-20121212+lfs but it is not installable
E: Unmet dependencies. Try ‘apt-get -f install’ with no packages (or specify a solution).”

Does anyone have an idea what to do? I would be very grateful!

Thanks in advance!

#19

Which firmware were you on when you performed the apt-get?

For firmware V3, just follow my instructions on point 3 and be sure to note the instructions carefully else you’ll break the WD’s webGUI.

For firmware v4, apt-get doesn’t work on this firmware as it needs debs patched with 64k page size memory. If you did, most probably it’s already messed up. You’ll need to reflash the v4 firmware to fix it. Read more on the 64K page size memory http://community.wd.com/t5/WD-My-Cloud/Building-packages-for-the-new-firmware-someone-tried-it/td-p/768007

#20

Thank you for your quick response!

That explains a lot. Unfortunately it was the V4 so I better reflash the firmware… I don’t feel to confident about this 64k thingy - is it possible to flash a V3 firmware and downgrade or would that rather wreck everything?