OSD for audio/subtitles - how to turn this off?

I’m using the WDTV Live gen 3 (no internal drive) and I have this problem. Every single video file plays and a on screen display of the audio and subtitle comes up. For presentation to clients or for screenings at a movie theater, this is completely unacceptable.

Will this be fixed? If not, I need to return this unit immediately and consider other brands.

This has been requested for ages but WD just doesn’t care. You might get lucky with the modded firmware though, haven’t tried it myself.

It can be fixed with themes.  No need for firmware hacks.

Search in the Hub theme section-- many of the themes are also compatible with the SMP.

yeah, it’s pretty easy to remove :wink: (6kb theme remove’s audio/subtitle osd from video/dvd/iso playback)


Even better. Is there a way to have an animated screensaver, by theming the SMP to play back a video or something?

I just downloaded every theme and tried each one and the audio data still shows up on every single video file.

Okay, so I have this zip file and the XML files… Yeehaw, what do I do with them?

Copying them to the root of my drive didn’t do anything. Still getting these annoying audio on screen displays.

I am getting VERY frustrated. I think I’m going to return both of my WDTV’s if this can’t be fixed. I used to recommend these from the old models to anyone, but I cannot in good conscience continue to support a product that doesn’t support its users.

I cannot support WDTV because it isn’t simple. I’m not a programmer. I don’t know what a SMP is. I didn’t think I’d have to go routing around on multiple forums and attempts hacks to do something simple on the device.

No hacks involved at all.

It’s a three step process.

Launch the Web UI.

Go to the THEME section.

Load the theme file.


I don’t know how it could be simpler…  

SMP, by the way, is the box we’re all talking about.  Streaming Media Player.

Simple… Where is the web UI? 

I don’t see it under any menu or sub menu. User Themes are under APPEARANCE.

I don’t guess you’ve read the manual, then?


See page 43 thru 45. (in the English version, at least…)

Stil - as I try to upload this via the user interface via my wireless network through itnernet explorer - it says PLEASE WAIT.

I let it ride for over 40 minutes (on the 7k zip file), then let it go overnight for over 9 hours - and I’m still waiting.

Yeah - it couldn’t be easier - if it wasn’t a piece of junk.