OS5 cannot setup Cloud Access or Media Server RESOLVED

re support case 201209-000762

ANY SUGGESTIONS are welcome from the community as support does not yet have any solution.

ISSUE:
Upgraded MyCloud EX2 Ultra to OS5
During upgrade could not setup Cloud Access due to “Error Something went wrong, please check that you have an active Internet connection and try again.”

After upgrade I can access the Dashboard but still cannot setup Cloud Access due to the same error.
I had Cloud Access with OS3 directly prior to OS5 upgrade.
Per support agent I have done 4sec reset and 40sec reset but still get the same error trying to setup Cloud Access.
Network Setting show I have Internet Access, MyCloud EX2 Ultra ip is 192.168.1.157
Tried with multiple supported browsers from multiple desktops.

Also, I had the OS3 Media Server enabled prior to upgrade, which is no longer in OS5.
To re-enable media serving I added the provided Twonky app, however I cannot configure because MyCloud cannot open the config page. Same issue with Plex.
Twonky is on port 9000 and Plex uses 32400.
Neither port shows as open/enabled via a full port scan.
I can however config FTP and port 21 does then show as open.

Additional observation, if I go to Network > Port Fowarding > only FTP shows vie ‘Select Default Service’ i.e.config sensing what services are on. I can manually configure via ‘Customize a Port Forwarding Service’ but it seems to me if the config is not sensing HTTP/S then there is an issue.

At this point post OS5 update the devise is functionally inoperable for my needs, i.e. cloud access and local media Server.

Thanks in advance for any help.

@ShawPark

Did you attach the My Cloud System logs to your support case?

My Cloud OS 5 doesn’t use the same port ranges as My Cloud OS 3. https://support-en.wd.com/app/answers/detail/a_id/29968
Port Forwarding remote access for My Cloud OS 5 is not supported ns the AdminUI because it is not possible to hardcode
an external HTTPS port like it was in OS 3.

QUESTIONS:

  1. What Network Router are you using?
    Are you in a double NAT configuration (two routers) or is your My Cloud connected to the Internet facing Router?
    Does your Router Support UPnP and is UPnP enabled?

  2. When you access the Admin UI dashboard, do you get redirected to this type of address and port?

    https://device-local-xxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx.remotewd.com:8543

  3. When you Configure Twonky, what URL and error message do you get?

    http://xxx.xxx.x.xx:9000/webconfig

  4. Is your router blocking port 8443?

    Computer Browser URL
    http://portquiz.net:8443

    My Cloud via SSH
    curl portquiz.net:8443

  5. Can you ping, trace and lookup google DNS server 8.8.8.8 with no packet losses?

    Computer Command Prompt
    ping 8.8.8.8
    tracetr 8.8.8.8
    nslookup google.dns

    My Cloud via SSH
    ping 8.8.8.8
    traceroute 8.8.8.8
    nslookup google.dns

I was not asked to attach the MyCloud System logs to the case. How do i do that? I can see where to ‘view logs’ but not save a copy I can upload.

I understand about the forwarding, I removed the OS3 settings I had, and in the process saw only FTP showed as an option, so just mentioned that as a FYI.

1/ Spectrum modem (not wifi) connects to internet. Lynksys Velop wired to Spectrum modem. No double NAT. Velop supports UPnP and it is enabled.

2/ UI Dashboard does not redirect, stays on http://192.168.1.157/

3/ Chrome= This site can’t be reached 192.168.1.157 refused to connect. Try: * Checking the connection * Checking the proxy and the firewall ERR_CONNECTION_REFUSED BTW I have check f/w and anti virus wifi router, no block is apparent to me. Have also turned off al f/w and antivirus and tested, same result.

4/ Not blocking. '$ curl portquiz.net:8443 Port 8443 test successful! Your IP: xx.xx.xxx.xxx. VIa Browser. Need to resarch how to SSH from MyCloud, do you have a cheat sheet?

5/ Yes, ping and traceroute, avg 24ms. Via Browser, I don’t know how to SSH from MyCloud, do you have instructions?

  1. Please edit your post and delete your Public IP address from the port 8443 test.
  2. If the UI Dashboard doesn’t redirect, then there’s either an internal Name Resolution Issue, the EX2 Ultra cannot access the internet and doesn’t get a Trusted Cert or something else going on.
  3. For Twonky, I’m assuming the computer is on the same subnet and network?
  4. Here’s how to get the system logs

1/ Thanks
2/ OK, thats progress… is there a next step?
3/ Yes, home network with just one subnet.
4/ Uploaded to incident # 201209-000762.

Thanks

@ShawPark Thanks for the logs.
Your EX2 Ultra is in JBOD mode but Volume_1 (Drive #1) is not seen by the enclosure and not mounted at all. No errors in system logs because the drive isn’t seen. Volume_1 is required for device and app configuration as Volume_2 of JBOD is only used for storage. Did you remove Drive #1 from the enclosure?

  1. Power off the My Cloud
  2. Remove and Insert Drive #1
  3. Power on the My Cloud
  4. Check your Storage Screen to ensure both Volumes are mounted

I’ve only ever had that one drive in the unit, where it is now.
But I can add another, which I’ll do now and let you know.

UPDATE…after looking in the device the existing drive is in the no1 physical slot of the EX2 but system calls it Volume_2. I’ve added a second JBOD drive into physical slot 2 which system now calls Volume_1. Hope you can see the uploaded photos.

After a reboot I was able to setup Cloud Access and after reinstalling the Twonky app I was able to open the config.

So at this point I think we can call this incident resolved. Thank you.